Brain shows bump sensor but is not there

I too have a similar issue that no amount of updating is fixing. I have a permanent bumper switch showing on port 5 when it is empty. If a motor that isn’t affected this way is plugged into port 5, it shows as a motor, but once it is removed, shows up as a bumper again. No%20Motor%20On

Reset the brain or the @jpearman can tell u what to do

Have you tried right-clicking in the switch and then seeing what pops up? Might say something like ‘fix issue’ or similar. Don’t know for sure, just an educated guess.


check the port on the IQ brain for any damaged pins or other debris that may be causing the brain to think a bumper switch is plugged in. The bumper switch is a completely passive device, if the IQ brain does not find a smart device like a motor, it then checks to see if a bumper switch is present by measuring the resistance of certain pins in the connector. If the pins are damaged it can mistake this for a bumper switch being connected.


Thanks for the help. Your the best jpearman

I used air to blow out the port. I can see no visual difference between the ports to indicate damage. I did a soft reset with the brain and then a hard reset with both up and down arrows. When I plug a motor into that port, it shows a motor. As a last resort, I sprayed a touch of contact cleaner in the port.
Nothing has worked so far. Do you know what pins I can use a multi-meter on to check resistance? Thanks for all your help! Brad

Umm… I do not no any u can use for the vex iq brain but I know one for V5 but I am sure that will not work Iq, a smart option is to call vex and maybe they will replace your brain. Idk, I never had this problem

If it’s under warranty, this might be a good idea. If it’s older than 3 months, this will be quite expensive.

1 Like

Right, I will never want my brain to do that, bc my brain is 3 years old