Brand New Cortex is Having Problems... Please Help!

Hello all! We purchased a brand new cortex before rebuilding our robot because we were having some issues with the old one and wanted a solid one for our upcoming states tournament (in one week.) Just last night we got our new robot operational and we are having all sorts of issues. Port 9 is dead … no idea why, it hasn’t been used yet. Also, our robot just randomly shuts down (even if we aren’t touching it/ making changes to code.) We turn it off then back on again and it takes several seconds for lights to come back on again. We also are having all sorts of VEXnet key problems. Sometimes when the robot is bumped, it will disconnect the VEXnet key and give a red light. This is a BRAND NEW cortex. Am I missing something? Did I do anything wrong? … Or did I just get a dud, and if so will VEX replace it? We have a tournament this Saturday then states the next. :confused:

Wait… WAIT…WHAT!!! I thought it hasn’t released yet. Let me check the vexrobotics website…


Im just kidding asides, have you tried re-updating the firmware to ensure its up-to-date?
A lot of these issues can be fixed by re-updating the firmware, but it may not be the issue sometimes.

Vex is really good about replacements, but Saturday is coming fast

@CATaclysm Delta_II I haven’t tried updating the firmware yet, I will try that tonight when I meet with my team. In the mean time, out organization needs to have extra cortexes on hand anyway, so I might order a one-day air mail cortex just in case so that we have it in time.

@TriDragon That’s good to know, I might contact them if I determine that firmware isn’t the problem.

Thanks all, I’ll see what I can figure out tonight.

Return it vex will usually send you a new one

@CATaclysm Delta_II Stealin my Joke… :confused:

JK :wink:

@ethan_matlack I suggest you update firmware on cortex, review your code (there might be something messing you up, but I doubt it), and just to be safe put a fully charged battery on there.

Best of luck,

To give everyone an update:

We found an old cortex off of another one of our team’s bots and used that instead. We are shipping the dead one back. I tried resetting firmware, doing the config button, etc, etc, but we still had problems. Good news is though we are working again!

Side note:
With no practice whatsoever (thanks dead cortex) we walked away with the finalists trophy this weekend. :slight_smile: Looking forward to states!