Bricked Brain? Help, please!

First year team here. We have somehow managed to brick 3 brains in a week. Luckily we’ve overnighted new ones. Our robots have worked great up until the new update. I’m not sure what keeps happening. I have pressed up and down and check to put it in recovery mode and it is recognized by VexOS, but as soon as I begin to install the brain goes to the VEX screen and VexOS says to hit the check mark to turn the brain on…

Any suggestions?
I have tried two different computers, uninstalling and reinstalling VexOS, different cords, different batteries.

I do not have a radio currently installed in the brain, would this make a difference?

Any and all help is much appreciated!

Are the Brains not actually switched off when it says to hit the check then? It’s normal for them to reboot in an update but they need to be turned on again manually during the process.

@calvc01 right, it’s not actually turned off. When it initially turns on it goes to this screen…

image|666x500

image

image

It starts to download then goes to the last screen and now it doesn’t read that anything is there.

looks like you may also have VEXcode blocks open, make sure all other programs that may communicate with the brain are closed.

1 Like

Thanks @jpearman! I just tried that and it still didn’t change anything. I am so frustrated because I can’t figure out what’s causing it or why it is happening.

Is the brain showing the “vex” screen then shutting off?

@UnknownAsteroid it’s showing the VEX screen but it just freezes on that screen. I have to take the battery out to get it turned off

The bootloader could be corrupted. I’m not entirely sure. If you haven’t I’d call vex. Another possibility is your computer has some static charge that is causing a short circuit.

Sounds like short circuit to me. May be caused by your computer? Or even battery

Can you reboot your laptop. I’ve had cases where the USB connections get hung (Windows 10 feature).

Reboot laptop.
Run the VEXOS tool
If it seems to hang at the VEX boot loader screen, shut down the VEXOS tool (not the brain) and restart it.

The only time I’ve ever bricked a brain happened when a Roboteer drilled through the screen (they were working on a science fair project)

@Foster I just tried that and it didn’t work. It is so frustrating. It is just stuck at the VEX screen. When I shut down Vexos but left the brain on When I restarted it it doesn’t registered that there’s a powered on brain connected.

@sstar Sorry to say that I’m stuck also. I would have said try other USB cables, there are a ton out there that just have power, not the data. But your screen shots show that there is data back and forth.

Replacing them is the best path. Based on your original posts, the replacements should be there.

Sorry to hear you’re having problems with your VEX IQ Brain. Have you reached out to our Tech Support line yet? We’d be glad to help you troubleshoot this issue or setup a replacement if needed.

Please give us a call at 903-453-0802 at your earliest convenience!

3 Likes

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.