Bumper Switch causes Motor error need help

Hello,
I have tried adding bumper switches to my autonomous coding. I tried with two bumper switches and my code which is in an if-else loop works. But I’ve added 5 bumper switches and during download to code I keep getting varying motor configuration errors. Sometimes it is Motor2, Motor3, Motor4 or sometimes across all. The error is Program usesa motor that is not equipped in hardware. I’ve checked the port connections, downloaded firmware, taken off battery and rechecked everything. This happens only when I connect bumper switches. Any ideas how I can resolve this. My code is something like this
while (true){
if(SensorValue(bump1) == 1){
//do something
}else if (SensorValue(bump2) == 1){
//do something
}…//do the same until bump5 else if(SensorValue(bump5) == 1{
//do something
}
I’ve tested this piece of code with 2 bumper switches and it worked fine. I have 6 motors connected from Ports 1 to 6 followed by 5 bumper switches from Port 7 to 11.
Coding is done using RobotC4.0 for VEX IQ Rocotics 4.x
Any help appreciated.
Many thanks

Have you checked the VEXos utility? You may need to download the OS to one or more of the bumpers.

Thanks I connected all the switches and motor to the brain and used VEX Os Utility. Its working now.