'C:\WINDOWS\system32\cmd.exe' could not be spawned

I have started getting this random error when uploading pros projects to the v5 brain. The whole error says: image
This is also opening an inspect tool on the left-hand side of my screen. The error on that reads:

C++ (cquery) rpc.sendRequest initialize threw ResponseError: Failed to index C:\Users\niyam\My PROS Project/src\main.cpp
at handleResponse (C:\Users\niyam.pros-editor\packages\ide-cquery\node_modules\vscode-jsonrpc\lib\main.js:436:48)
at processMessageQueue (C:\Users\niyam.pros-editor\packages\ide-cquery\node_modules\vscode-jsonrpc\lib\main.js:263:17)
at Immediate.setImmediate (C:\Users\niyam.pros-editor\packages\ide-cquery\node_modules\vscode-jsonrpc\lib\main.js:247:13)
at runCallback (timers.js:789:20)
at tryOnImmediate (timers.js:751:5)
at processImmediate [as _immediateCallback] (timers.js:722:5)
error @ logger.ts:23

I have tried multiple times resetting my PC and redownloading windows but I have had no luck. The CMD.exe file is in system32 and it is added as a path on my computer. I cannot figure out what is causing this error. If you have any suggestions I will willingly try them.

Many Thanks Niyam

It might have to do with Windows 10 liking Powershell more then CMD.

image these are all the files in my path. I think it should still work but it hasn’t so I don’t think that would be the issue

I’d guess it’s a permissions issue.

Are you running on a school/managed computer? Try opening a command prompt manually and see if that works. If it doesn’t, your account probably doesn’t have permission to open it and so Vex code doesn’t either

Edit: just realized you pulled up your path so this likely isn’t an issue

1 Like

it is on my own computer…I have tried running pros as administrator but I’m getting the same error. I can open and use the command prompt and it functions fine.

https://github.com/purduesigbots/pros-atom3/issues/34 found this link but don’t think it was ever solved.

Whats the path to your project directory? (Specifically, is there a space in your username)

Hotel referred to spaces causing issues in that report

2 Likes

C:\Users\niyam\MyProsProject is the path

Was the path you posted earlier your user path or system path?

It was the system path
this is my user path:image

Does running a start command for CMD.exe work?
start C:/WINDOWS/system32/CMD.exe

image
doesn’t come up with any issues so I think so.

I’m out of ideas for the time being. @jpearman or @hotel can probably be of more help.

talked a bit on the discord and I think it might be from a new windows update

Definitely could have had some effect - I had to roll back windows after a ton of software I use broke after update 2004

2 Likes

I’ve had this issue happen when I was trying to show someone how to use PROS on their computer, and disabling their antivirus fixed it. For some reason, some AVs find PROS spawning cmd to be suspicious, so try temporarily disabling any realtime protection your computer has on. I haven’t had any issues with Windows Defender, so if you don’t have another AV, just ignore this.

4 Likes

Did anyone else find any solutions to this? One of my teammates is having the exact same issue and we’ve tried all the possible solutions we’ve found relating to pros and nothing has worked.

This is also a known issue with the latest version of the editor that was rolled back, so if possible reinstall the PROS Editor

He’s reinstalled it several times, but his latest reinstall was yesterday after a windows reset and is still having the issue. Did they roll back that version just now?

For now I have used the prosv5 mu command in the cmd terminal to upload programs…i talked to hotel on the discord server and it is to do with a new version of windows which apparently broke it and it was unlikely to be fixed soon. For now I would recommend just using the slightly longer way of uploading until someone gets to the bottom of this issue.

4 Likes

to clarify: i’m not actually sure what’s causing this. we’ve seen something similar crop up recently on macOS too so it’s not just a windows issue as far as i’m concerned. my worry is that something broke in the stack of code we use to support the atom plugin (terminal plugins have a long history of behavior like this), but i don’t know which part it is exactly.

in the meantime, using the CLI is the recommended workaround :confused:

2 Likes