Cable Blinking Red

When I’m running some skills runs all of the sudden my clamp motor just stops working and I go to check on it and it’s stuck so I turn off my brain and turn it back on and then the cable connecting to the motor just slowly starts blinking red and the motor won’t work and after we just replaced it with a new motor and it worked but all of the sudden it happened again to the same clamp but to another motor and we can’t keep changing motors especially because you can’t buy them because they are out of stock so what do I do? (Both times it was plugged into port 5 on the brain) (both times it was for the clamp) please can someone help me, thank you

1 Like

Try changing the port on the brain that you are plugging it in to (both physically changing it and in the code so that it will actually function when you move it), this has happened to my team a few times this year and that worked 90% of the time.

When its blinking red, that means it only has a stable connection of one end. Plug in a wire from another motor to see if it becomes a solid red. If this works, you have to change ports. If it doesn’t, plug the wire into a different motor to see if it becomes a solid red. If so, something with the motor connection was wrong. Of this also does not work, you have a bad wire and need to make a new one.


At a comp our ports kept burning out in our claw because of static electricity (the port was flashing red). We fished this at the next comp by using anti static spray on the wheels, claw, and base