CAD download issues on VEX website

Hey @DRow I have been trying to download cad files from vex but I’ve noticed some issues on the website:

1/ CAD files are downloading as .STEP.txt files - when you click the download button next to the file you want to download you get a .STEP.txt file when you need a .STEP file. I’m able to remove the .txt extension once downloaded so the files can be opened in CAD software but it is quite annoying to do this for every file and it would be great if this could be fixed.

2/ Clicking ‘Download All Files’ refreshes the page and displays ‘File not found’ at the top of the screen. (This happens on all product pages.)

3/ Some CAD files are missing from their pages - I haven’t had time to look through every page but I have noticed that there is no CAD file download for the V5 smart motor and there may be others.


1/ Some products that are listed on multiple pages don’t have their CAD files listed on both pages as well, this makes it harder to find them. For example aluminium c-channel is listed on this page but its cad files are not shown here, they can be found on this page though. It would help if the CAD files are listed on all pages where a product is listed.

2/ Could VEX put all the CAD files on one page to make them easier to find.

BTW I am using the Safari browser on a MacBook Pro, I also have managed to get the files I needed but I thought it would be useful to let you know these issues.

Also has anyone else noticed any issues while trying to download CAD files from I expect there could be more.

In the attached document which discusses stuff about CAD, there are some links to complete parts libraries.

V5 cad files can be found here:

A while ago I converted many of the V5 parts to solidworks and posted them in this forum here:
CAD for VEX Robotics.pdf (191 KB)

This is weird. Definitely not something I’ve seen happen before. I unfortunately wasn’t able to replicate the issue with any of the computers (both Mac and PC) that we tested here in the office. Every file we tried downloaded as a normal .STEP file. What were some of the files you downloaded that gave you this issue? Just want to make sure that it’s not something wrong with the file type before going any further on this one.

I was able to replicate this one. I’ll put it a support ticket to our IT team to have them fix it.

This one was on me. When we rolled out the V5 Smart Motor Gear Cartridges last week, I swapped everything over to a new page, with the same URL. I simply just forgot to include the CAD file while doing so. That file in particular is now up on its product page (as are the missing Aluminum C-Channel files you mentioned). If you run across any other pages that are completely missing CAD files, just let me know and I’ll get them added.

@DRow Thanks for looking at these quickly.

I have tried to download the V5 products CADs (battery, motor, brain) and I get the STEP.txt files, I haven’t tried other products.

These are the download links I used:

And this google drive folder has the files I downloaded from those links. I would upload them here but the forum doesn’t support .txt files. :frowning:

Also, I just found that when I click ‘download all files’ on the newly updated V5 smart motor page I do actually get a folder downloading with a normal .STEP file for the motor. The other ‘download all files’ buttons on other pages don’t work yet. I still get a .STEP.txt file however if I just download the individual smart motor cad though.

Also some more detailed hardware/software specs
Browser: Safari V11.0.3
OS: MacOS High Sierra V10.13.3
Hardware: 13" Retina Macbook Pro Early 2015

Also I tried to download these files from the website using chrome on the same computer , it works normally and I get .STEP files. Maybe this is a Safari related issue?

@Download Complete Same thing for me. .STEP.txt on Safari and .STEP on Chrome (MacOS High Sierra 10.13.6)

I’ve had it happen using Safari on a Mac. Other people have mentioned it in other threads, too.

But there is a trick. You can delete the .txt from it. You have to know how, though. You can’t just click on the file name to do so. You want to use Get Info. In the Name & Extension box delete the .txt and it will double-check if you really want to change the file type. Yes, you do. Then you’ll have a genuine .STEP file that you can load/upload properly.

Yes this is the method I used to fix the files, it works well but its a pain to do.

I’ve been told that the issue you’re having with Safari downloads, as well as the broken “Download All” button have been fixed. Thanks again for bringing it to our attention!