Cannot Get Vex System Info

I’ve been having this problem with my new computer I got in September and being able to download my programs into any Cortex.

Here is the process:

  1. I press “Build and Download”
  2. It successfully builds the file
  3. It starts trying to download the file
  4. The Intellitek Loader window pops up and on the bottom right of the window it flashes “Com Port is open…” to “Not Connected” back and forth around once per second for about 8 seconds.
  5. It gives me a message “Cannot Get Vex System Info” and after pressing Okay to that message, it asks if I would like to try download it again. If I try, it fails still.
  6. After, Cortex becomes corrupted and cannot download from any computer, including ones that it worked for previously. All other computers get"Cannot Get Vex System Info."
  7. The only way to fix the Cortex is to hold the “Config” button on the bottom of the Cortex and plug it into the computer.

Things I have tried to fix this problem:

  1. Reinstalling EasyC, twice from downloading online and once from a CD
  2. Using another USB port
  3. Reinstalling the drivers for the Cortex
  4. Using another Cortex
    All efforts were meaningless as I still get the same problem.

The problem is with my computer, but I do not know what. At first, I thought the drivers were bad, but I reinstalled them twice already.
It is an ASUS N55SF.

Please help me with this issue as I have tried everything I could and the seniors at my high school have also never had this problem and are stuck too. I bought this computer for the sole purpose for robotics so I really need to get this working. If you need any other information, please reply.

Thank you in advance.

Are you using a Direct Download Cortex -> PC or over the WIFI? Have you tried the new version of easyC? We changed the direct download from HID (problems) to Serial which is very reliable.

Not really sure what serial is; I’m new to all of this stuff. I use the Cortez connected to my computer with the orange male to male usb cable. I never tried wireless, but I’ll try it today once I’m in the garage. Also, all of my software is up to date; got it straight from intellitek’s website.

Well, make sure in the device manager under “COM & LPT Ports” you have a device called “Vex Robotics Comm Port (COMxx)” with no errors. Also, make sure your robot controller is turned off prior to you connecting the Cortex to the PC.

Yes, in the device manager, the drivers are up to date and working. Windows also decided I had the most up to date software for it. I’m going to try transferring the drivers from another computer to my computer.

The link to reinstall the drivers are in the start menu. If they are working then you don’t need to change anything. What is the com port number assigned, you call our support line and we could remote in and take a look.

Here’s an update so far of my progress:

I was able to send hex files using the VexNet keys. The program is sent into the Cortex properly, but there are some issues on the computer’s screen. When downloading using the intellitek loader of EasyC, a blue bar shows the progress of the job. When the blue bar hits 100%, I do not get a successfully downloaded message. Instead, the intellitek loader window freezes up and does not respond to anything. The only way to close it is to end the process in task manager. I’m not sure why it causes this, because it obviously isn’t my processor being too slow (i7 2630m). Also when building a hex file, it takes a long time building all of the user functions oddly. It takes around 3 seconds per function and I have around 10 functions. On the other computers and one of the seniors Dell XPS 15 in our garage, it takes close to 0.1 of a second per function.

Regarding the com ports used, I normally use Com Port 2, though I have tried all the other USB ports which are 3,8, and 9. I have already reinstalled the drivers multiple times too.

Tomorrow I’ll give the support line a call once I get in the garage.

I’ve also decided that my last resort is going to be a clean reinstall of Windows without all the bloatware that Asus gives you. I’m a little confused about how the EasyC license works. I’m sure we have a multi-user license key, so I was wondering how to unregister myself from it before I reinstall Windows. Would uninstalling EasyC do it, or would I have to call the support line?

Thanks for the support, kingofl337

You can goto Help -> Registration -> Remove License.

Oh okay, thanks for the answer.

Sorry for not being able to update for a week, it seems I had some stuff to take care of and could not get to the garage.

Status so far:
VexNet Keys = WORK but freezes downloader window after download
USB Direct = Does not work

I have reinstalled windows, formatting my drive in the process. It was no use, as the problem still persists. I will try to uninstall my USB 3.0 drivers made by Asus to see if it fixes the problem.

Managed to MAGICALLY FIX IT! Sorry for caps, really excited to finally get it working after three weeks of dedication.

For all people who want to get a n55sf from Asus,

  1. Plug in Cortex via USB
  2. Look in device manager for Vex Robotics Comm Port
  3. Uninstall the drivers
  4. Look into the start menu under drivers and check in the drivers folder.
  5. Load the install of both drivers and uninstall if already installed.
  6. Restart Computer
  7. Reinstall the two driver
  8. ???
  9. Profit

It works perfectly as of now, well the USB downloading direct cable so far. Did not test if wireless would freeze up yet. However, I feel tomorrow it’s gonna crap out again somewhere in my gut. Hope it doesn’t. Thanks for all of the support in helping me overcome this problem!

If it does fail, give Vex a call maybe they will find something to make the driver more robust.