Cannot reach activation server

I am trying to enter a license into a preexisting RobotC installation that has passed the 30 day’s. I am getting a error saying that it cannot reach the activation server and to check my connection. I am on the very computer that will not connect with the server now. I have attached a print screen.

Thanks, Thomas
RobotC Activation error.jpg

I have turned off my firewall and tried to activate and there was no difference. I have tried from 2 different locations without any luck. I uninstalled the previous installation and installed 3.54 to see if I could activate it and could not. When I try and do an online update I get an invalid url message.

Is there a problem with your servers or do I need to keep looking on my end?

We were having some server issues yesterday which should now be resolved. Please try the activation again and let us know (via the support ticket, if possible) if you run into any other issues.

Thank you, and I apologize for any inconveniences this may have caused.