Cannot Update Cortex

For some reason i try to put on a program on a cortex, but i cant because i need to update it to i think it is 1.25 but i cant and is stuck on 1.23 or watever it is for some reason

fyi this is robotc
(and i couldve edited the previous one)

This happened to us once when we first got our cortex and we tried to power cycle and it worked fine. If you tried that and it didn’t work, make sure your RobotC is also up to date(I don’t think there were any updates lately but I’m not sure). If that still doesn’t work, there might be something wrong with the cortex. Is there a notification you get when it fails to install?

it does recieve a notification wen it fails, infact, it says that there isnt a comm link to device everytime

Try a different USB port, and don’t use the update button, go into the settings and use the manual update and try a few of the different files, sometimes you have to use an older version for the new one to load.

i have tried this but to no avail and still have issues

hehe I remember this…

still responging to all my posts eh?

yerp. I forgot about your account. :stuck_out_tongue: are you doing vex in mcBride?

yes, take this to the private chat?

skewer.