Can't create directory 'build/src' when building the program

I’m trying VEXcode with my laoptop(Win8.1 OS) today and got an error at the first step, I opened a sample program(nothing changed)and click on the biuld button, then I got error message as below screenshot:
%E5%9B%BE%E7%89%87

It can’t create the directory build/src, I uninstalled VEXcode and reinstall it again, build the program, got the same error still. Then I switched to another laptop(Win10 OS), do the same operation, it can build the program successfully.

Not sure if this is only my laptop issue, or a VEXcode bug with Win8.1.

Any suggestion?

Create a folder in your project folder called build. It should work after you do this.

Yes, it works! Thanks! though I have to create a build folder whenever create a new project:joy:

It’s a known bug when you have perhaps other unix like tools installed on the PC, we should have this fixed in the next preview due out next week.

1 Like

I did this and I still get the same error. Does anything have to be in the folder?

Are you on vexcode preview 2

what is that. Is it another version of vex code?

is it the update? If it is, yes I’m on it.

Yes the building error was fixed in it. Preview 1 projects still have the issue but if you copy over your code it should fix your error.

I wrote the code while in preview 2.

Have you tried making a new project and copying over the code?

Yes I have. I added the empty build file, but once I tried building it, it removed the folder from the project folder

Hmm interesting @jpearman any ideas?

does anything go inside the build folder?

No (20 character limit)

if you could try the following.

  1. create a new project
  2. edit the makefile and set VERBOSE=1
# VEXcode makefile 2019_03_26_01

# show compiler output
VERBOSE = 1
  1. click build
  2. cut&paste the contents of the output window into this topic. It should look something like this.
[info]: Project Path: /Users/james/Documents/vexcode-projects/Example1_events
[info]: Saving Project ...
[info]: Project saved!
unix build for platform vexv5
mkdir -p "build/src" 2> /dev/null || :
CXX src/main.cpp
clang -target thumbv7-none-eabi -fshort-enums -Wno-unknown-attributes -U__INT32_TYPE__ -U__UINT32_TYPE__ -D__INT32_TYPE__=long -D__UINT32_TYPE__='unsigned long'  -march=armv7-a -mfpu=neon -mfloat-abi=softfp -Os -Wall -Werror=return-type -fno-rtti -fno-threadsafe-statics -fno-exceptions  -std=gnu++11 -ffunction-sections -fdata-sections -DVexV5 -Iinclude -I"/Users/james/Documents/code/VEX_repos/advanced-cpp-editor-beta/Tools/sdk/vexv5/include" -I"/Users/james/Documents/code/VEX_repos/advanced-cpp-editor-beta/Tools/sdk/vexv5/clang/7.0.0/include" -I"/Users/james/Documents/code/VEX_repos/advanced-cpp-editor-beta/Tools/sdk/vexv5/gcc/include"  -I"/Users/james/Documents/code/VEX_repos/advanced-cpp-editor-beta/Tools/sdk/vexv5/gcc/include/c++/4.9.3"  -I"/Users/james/Documents/code/VEX_repos/advanced-cpp-editor-beta/Tools/sdk/vexv5/gcc/include/c++/4.9.3/arm-none-eabi/armv7-ar/thumb" -c -o build/src/main.o src/main.cpp
LINK build/Example1_events.elf
arm-none-eabi-ld -nostdlib -T "/Users/james/Documents/code/VEX_repos/advanced-cpp-editor-beta/Tools/sdk/vexv5/lscript.ld" -R "/Users/james/Documents/code/VEX_repos/advanced-cpp-editor-beta/Tools/sdk/vexv5/stdlib_0.lib" -Map="build/Example1_events.map" --gc-section -L"/Users/james/Documents/code/VEX_repos/advanced-cpp-editor-beta/Tools/sdk/vexv5" -L"/Users/james/Documents/code/VEX_repos/advanced-cpp-editor-beta/Tools/sdk/vexv5/gcc/libs" -o build/Example1_events.elf build/src/main.o --start-group -lv5rt -lstdc++ -lc -lm -lgcc --end-group
arm-none-eabi-size build/Example1_events.elf
   text	   data	    bss	    dec	    hex	filename
   6876	   1100	1064276	1072252	 105c7c	build/Example1_events.elf
arm-none-eabi-objcopy -O binary build/Example1_events.elf build/Example1_events.bin
[info]: build completed!
[info]: download
[info]: download completed!
1 Like

‘make’ is not recognized as an internal or external command,

operable program or batch file.

[error]: make process closed with exit code : 1

I get this error now^

Hi!
I have the same issue on my laptop. When VEX developers will fix it?

1 Like

I’m not sure which issue you’re referring to… also this is a year old thread, please start a new one if you’re running into issues.

2 Likes