Can't Get VEX Microcontroller and Remote to Link

I can’t get my microcontroller and remote to link.
I have put several hours into it and nothing seems to work.
I have updated the mastercode on the microcontroller, reconfigured both the remote and the microcontroller and have looked at the flow chart and Microcontroller/Vex Net user guide. Nothing will work.
A few details (I don’t have it in front of me trying to do this from memory)
when i directly connect the microcontroller to the remote they don’t recognize each other (nothing happens, robot won’t move, don’t link) and the vexnet light is the only light on flashing red I think
Batteries are fresh
When they are not hooked up by direct usb (dongles in) they seem to just constantly be searching.
Any help is appreciated, if you have questions just ask.

You are correctly ordering the turning on of the hardware right?

Cortex first then joystick

Which development system are you using ? (ROBOTC or EasyC) Which version?

Which version of master firmware is in the cortex?
Which version of master firmware is in the joystick?

How did you update the master firmware? Did you use the ROBOTC or EasyC downloader or the IFI/VEX firmware updater?

Was this working before or has it never worked?

Yes, I believe I have the order right
Easy C Cortex v.4 I think
2.81 I believe
? (It wouldn’t recognize the joystick)
I updated the master firmware through IFI/Vex Firmware updater
It has worked before It was working about 3 weeks ago then we started to rebuild our robot and I have been trying to program it for the last week but can’t get anything to connect, the code downloads from the computer to the microcontroller (direct usb) fine

It sounds like you need to re-flash the joystick, connect it using the USB A-A cable and use the IFI/VEX upgrade utility to upgrade it to a version compatible with the cortex.

2.81 is pretty old, I don’t remember which version that shipped with but the latest version of EasyC is and needs master firmware 3.23 in both cortex and joystick. The version of the IFI/VEX upgrade utility that ships with this is 3.2.8.

Anyway, re-flash the joystick, you may need to hold in the config button to put it into boot load mode. When you have done that then try and tether the cortex and joystick with the USB A-A cable and see if it works.

One other thing, is the EasyC code in a competition template? If it is a stand alone project that may also refuse to connect to a joystick, again, I don’t remember as I don’t use EasyC that much.