CDC RC serial link - unofficial reply

VEX tried to implement a standard CDC interface, and got it wrong.

I implemented the OSX version, I used the Apple CDC driver as a starting point and hacked that to make a VEX compatible version. You can read about what I did here.

The driver was released in this thread.

I’m not sure VEX has any documentation beyond this.

1 Like

Unfortunately the update to OS X El Capitan (10.11) has broken this driver (I believe). Does anyone have a working driver or resources I could use to build/port it?

I hate to say it but… Go back to 10.10? :stuck_out_tongue:

I have had nothing but problems with el captain.

So what happens? I have not had the need (or motivation) to install 10.11 and test the driver, I didn’t really expect any problems. Do you see the serial device under /dev ? Have you been using it with 10.10?

1 Like

I did have brief look at this last Night.

The driver is probably not broken, it does work using my flash download tool, but only on some USB ports (specifically those on an external USB hub). Some ports that worked under 10.9 and 10.10 now seem broken.

Bad news is that lots of developers have found similar issues with their drivers. Root cause seems to be that Apple has rewritten the USB stack for 10.11, from the release notes.

So I’m not going to devote any time to this right now (I have no time anyway and the problems have not affected me, I wrote the driver for my own use after all), perhaps in a few weeks/months when either Apple has fixed the issue or there is some documentation showing what changes are necessary I may address it. IMHO, it is an Apple issue and hopefully they will fix in a future release.

1 Like

Sorry for not replying sooner. It was not showing in /Dev which kind of killed all my attempts to work with it (I could find no more info on troubleshooting unless it showed there). I guess the hunt for my USB Hub begins! Thanks for the info.

Even when not working properly, the driver was detecting the cortex and it was showing in /dev. If you fire up the console you should see a message when the driver detects a new device.

1 Like

Yeah I have no idea what was going wrong. After a few (more) reboots and perhaps switching cables it works perfectly. Thanks for the help…