Chromebook (w/Chrome OS) can't connect via VEXcode IQ to VEX IQ brain

First time posting so hopefully it formats well.

My student and I are in two different states so I can’t just go over to help him. He recently bought the VEX IQ Super Kit.

My student’s Chrome OS version is:
Version 88.0.4324.186 (Official Build) (64-bit)

And he is using the VEXcode IQ that was installed through the Google Play store I think. His VEXcode IQ version is:

VEXcode IQ 2.0.5-825
SDK 20200714.17.00.00

I also had him update his VEX IQ brain using his parent’s laptop so his VEX os is Version 2.1.5

We watched both tutorials that use micro-USB cable and the wireless method to connect to the VEX IQ brain but both methods did not work.

Has anyone had a similar problem? What am I missing? My student only has a Chromebook to work with and his parents are using their laptops for work during the same time I meet with him.

Hey @bwong! I’m from the VEXcode dev team.

Does the brain icon in VEXcode change color at all when the brain is plugged into the Chromebook?

Also, there is a Feedback button in VEXcode at the top right of the application. If you could have your student send feedback using that as well we might be able to look into this more.

2 Likes

Hi @tbobik

When my student shared his screen, the window that appeared after typing in the VEX IQ brain ID said something along the lines of can’t connect try to power cycle the brain.

The brain icon stayed white when the brain was plugged in and Radio Data was off.

We also tried:

  • brain plugged in and radio data on ( brain icon on VEXcode IQ stayed white even after power cycling the brain)
  • brain unplugged and radio data on (the up/down arrow appeared with a line connecting the two arrows on the brain’s screen but the VEXcode IQ still showed a white icon and the same power cycling message)

Sounds good, I only meet with him once a week so it’ll have to wait until 3/22 if I want him send feedback. It’s tough describing directions via email only to him.

Have you tried a different usb cord? I know that some usb cables don’t support data transfer. I’m also pretty sure that vexcode iq is on the chrome web store too. (I don’t know if the chrome web store version is different from the one on google play)

2 Likes

I forgot to ask him if he has similar cables! Will try that next week as well.

Validate that he is not using the Android version of VEXcode IQ on a Chromebook. You can validate this by seeing if VEXcode is asking to make a Bluetooth Connection versus looking for a robot via USB.

https://link.vex.com/vexcode-iq-blocks-chromebook

The Android version of VEXcode IQ is not officially supported on a Chromebook.

1 Like

Sure, I’ll ask him next time what kind of prompt appears.

Making sure I’m interpreting this correctly, is the link you posted the version that supports on a Chromebook?

This was a big help. Chromebooks should not get the app from the Google Play Store but instead as an Extension from the Chrome Web Store.

@Hudsonville_Robotics @tfriez

Good news! We were able to connect his VEX IQ brain to his Chromebook!

We were in fact using the Android version from the Google Play Store previously. Today we downloaded the correct version linked by tfriez in his previous reply in this thread.

Thanks all!

4 Likes