Chromebooks Not Properly Connecting to Brain Com Port Error?

I just started using GEN 2 in my classroom. About 1/3 of my students can’t download programs via USB to the brain. It recognizes there is a brain attached, then when selecting com ports, it is listing "ttyACM and a number, not “com port”. I know they are the same thing, but no Book that gets this when connecting can successfully download a program. No error message when attempting to, it just doesn’t appear on the brain. Things I tried: Switching cables, brain, USB ports, updating firmware on brain . Tried solving every variable and no joy. What am I missing?

Thanks for reaching out.

Since you mentioned connecting to “ttyACM”, it sounds like you are using the web version of VEXcode ( on your Chromebooks. Can you confirm that this is the case?

Can you confirm that when you select the port for the connection, it shows the brain is connected when you click on the brain button in the top menu? It should looks something like the screenshot below.

When you do try to download the project to the brain, does the downloading progress bar show up? It looks like the screenshots below. Please note that it may only show up for a second or 2.


If all of the above is true, can you please try submitting feedback in VEXcode after you have tried to download to the brain. Please make sure that the diagnostic data is included and that you mention this forum post in the message so that I can find it. This will let me see what VEXcode is doing and identify what is failing.

Since you mentioned swapping cables and brains, I assume that the issue is with specific Chromebooks. Have you tired using a brain that was not working on one of those Chromebooks with another one that is working? just trying to eliminate that the problem is not a combination of the brain and computer.

Have you tried using different user accounts on the Chromebooks that are having issues? We have found times where some user accounts work, while others don’t. If this is the case, then you would need to work with your IT department to figure out what is different between the account settings.


Thanks for the quick reply! Sorry I missed some specifics. Yes, we are using the web based version. I use it on my regular laptop and it says “com port” and always works. I connect the brain and it turns green after I have selected one of the ttyACM ports. The download progress bar does show up. I believe I have tried swapping the brain to a working CB, but I’ll try again Monday to be sure. Each student has their own assigned CB they use all day for all classes. IT does lock them down pretty hard, a few new apps are running, I’ll look into that. I did just find out we have a mixture of CB models, I’ll check them on Monday as well. I’ll get that data to you Monday. Thanks so much!

All good, on missing the details. I always like to verify things anyway.

I suspect you will find that a specific model is always having issues, while the others are all fine. That could either indicate that there is something about the Chrome OS implementation for that hardware or the configurations for those deices/user accounts that is the cause of the communication issues.

One of the fun examples that was early in the VEXcode development was that the communications ports would be swapped causing connections to the wrong ports for one manufacturer. That was fix quickly in the code, but it shows how Chromebooks do not always function exactly the same.

I would still encourage sending the feedback from one of the machines with the issue. It should allow me to either find that there is a VEXcode issue, or point to a configuration for the machines.