Claw Problem - 7057D

I am part of team 7057D, a middle school team. We have been having a problem with our claw. When we had tested it, it worked, but after we transported it to a tournament, it stopped working. We have switched motor controllers, batteries, motors, and even cortexes, claws, and programs. The two programs I had tested compiled on RobotC, but when testing the program, it didn’t work. We had other teams come and help us figure out the problem, but we couldn’t find out why. If anyone knows a solution to this problem, please let me know.

From my experience I would just double check everything, it is very easy to wire it up incorrectly or miss something in your code. Just because the code complied doesn’t mean it will work!

I have at one competition accidentally added a bracket to the code the night before and it meant only some of our motors worked. We spent the entire day trying to fix the problem changing everything on the robot because of it. Also I didn’t make it past the denial phase of debugging (it worked before why not now) so I didn’t properly check the code over. Only after the competition did I realise the problem.

I put ports 2-9 in backward the first time I rewired this year. It was terrible. Double check everything again, check the formatting of your code, and I would recommend changing the port to try to pinpoint the problem.

Are you using a servo for the claw by any chance? We had one for a while and it would sometimes “reset” itself and change all the position values. If not, you can check if the motor has somehow broken by just plugging a new motor into the claw motor controller. If that doesn’t work, it’s a wiring or coding issue. Assuming you didn’t change any code from when it worked before testing it, it’s the wires. Make sure everything is plugged in (maybe unplug and plug it back in), and try swapping out your motor controller, as they are somewhat prone to breaking.

try everything the people above me said, and then check your program and see if your not missing anything, and if not, try testing a motor in the port the claw is plugged into, it may be a bad cortex. it may even be controller because its happened to me before and i was like… what the crap is happening lol

We have tried all of those things, and it still didn’t work. In the quarterfinals of one of the tournaments, our alliance provided us with a claw. That also didn’t work. They also showed us their successful program, and we used it, but it didn’t work.

It sounds like you have multiple problems which are making troubleshooting difficult. Try switching out all the wires and double check your code.

We have switched motor controllers, motors, and we have triple-checked our code.

If you switch out enough stuff then surely it must work. Otherwise a lot of your kit is broken or your doing something wrong.

Does the rest of the robot work?

The key is keep eliminating variables until you narrow it down. The variables here would be

the port
the motor control
the the motor
the claw
the software
the controller, assuming you are using a controller

I’d write simple program to just power the motor in one direction, remove the motor from the claw and run the program. If that works then the port, motor control and motor are good. While the motor is off the claw see if the claw opens and closes by hand. Assuming all that worked, put the motor on the claw and try again. If that works, write a slightly more complicated program that runs the motor when a button on the controller is pressed.

Thanks, we will try that.

Check if it’s a build problem * (I can only build, alright.)* It might be a problem with the motors incorrectly functioning. If I were you, I’d rebuild the claw and redo the program from scratch. That would simply eradicate all your problems at once

We did that already.

You rebuilt the whole claw function? And the problem is still the same? Then, I think it might be a cortex problem, motor, or connection between the motor and cortex problem.

Thanks, we tried a simple program with the motor, motor controller, and cortex, and it worked. We still have to test it when the motor is on the claw.

Great! We’ve eliminated a lot of possibilities. Before installing the claw, see if it can be moved by hand opened and closed, to make sure nothing is physically obstructing it.

It can open and close by hand.

Cool! So now we would expect that if you install the claw on the motor it should work.