Code Not Uploading/ Not working at all

My team has been having very weird problems with our brain, not receiving updates from the computer. I have change slight numbers in velocity to test if my code was uploading. I have seen no indication that it is. Has anyone seen this before?
Edit: I have tested it some more. It will only upload randomly when i try it.

Can you send pictures of some sort or screenshots of what your code is doing while you try to download it? That might make it easier to fix your problem.

Have you tried checking the wires you are trying to upload it with? Not only the coding wire but the wires moving the robot. One time my team was having trouble uploading code, and it was that the wire from the remote to the brain went off and on, messing up our signal. Also, make sure the brain is updated to the newest version. Other than that, we would need to see photos to determine if it is something else.

Have you tried plugging it directly into the brain?

The micro usb cables notoriously wear down and we had one completely break off our brain, you could try using another brain or different cables to troubleshoot connection. You could also try to fix minor bugs in your code and compile the program before uploading it to the brain.

1 Like

Try writing a basic drive train move forward 10 ft. It that doesn’t upload correctly then it is most likely a cord/bot error. If it does upload correctly, then it is most likely coding issue.


I will try this, but we did change the upload cord.

The compile might fix it. I was thinking it could possibly be file size since I am running fancy code. I think it is unlikely though, because the code uploaded randomly with the same file size.

Yes, it did not change anything .

I will do this soon, I hope you can help.

We have tested and found that it is not the brain that is having a problem. The code seems fine, but it will not properly upload and change. When I upload the code it does not change. I think it may be the compiler, because when I tried a new brain it did not upload new code , but the code that had not been changed.

Hmm, what type of code platform are you using? Our programmer has used rust and c++, and he has 100’s of lines of code with no problem uploading. It does struggle to run the program though.

Plug your computer cord into your controller, and hazah! Magic downloading! Works for updates too I think

also make sure you’re updated to the latest version

Is the project recompiling ?

you were asking about header files in this topic.

Depending on how you have structured the project, the build system (makefile) may not understand that you have made a change and skip building.