Color sensor not showing up when debugging


#1

I am using Graphical RobotC for VEX Robotics.

I am trying to check the values that the color sensor receives, but the sensor is not showing up at all. I
have put the color sensor in the Motors and Sensors Setup,

but when I debug it, only the bumper appears.

I have the color sensor connected to the Port3. I have tried putting different categories in the Motors and Sensors Setup (like Hue or Grayscale), but it has not worked either.

I would thank any help provided.

error.PNG

error2.PNG


#2

I have tried to manually add it by right clicking in the sensors section when debugging. When I select port3, this appears automatically:

Color - Not Active. When I select colorHue and press OK, nothing happens.

When forcing the program to show me in the screen of the robot the sensor value, by doing this:

This message appears on the screen:


error3.PNG

error4.PNG

WhatsApp Image 2017-12-14 at 16.40.59.jpeg


#3

im new to robotc myself…so bear with me… i believe the de-bugging message is telling you that under ‘motors and sensors setup/sensors’, you are telling the program that you have the bump sensor attached to port 8, but when the program checks the actual port 8 on the brain, it is not finding this sensor connected. so i would first check the brain… do you actually have the bump sensor attached to port 8? if not, then make sure the ‘name’ section under ‘motors and sensors setup/devices’ is blank, and set the ‘sensor type’ to ‘no sensor/motor’…im not sure about the rest of it, but hopefully that will help with the ‘debugging’ part of your post? good luck


#4

Or is it stuck in the wrong color mode, ie: grayscale, 3 color, of 16 color.