Communication Issues

I am having major communication issues between our VEX Cortex and the computer. The Cortex will show up when first plugged into the computer and then when I try to update or download code it goes away and tells me to check that the device is connected to PC. This problem keeps us from using the equipment in my class and we need immediate assistance.

I have spent close to 10 hours troubleshooting and through email trying to get this fixed with no resolution.

The device shows up in the communication port and then says offline after we try to do anything with it. They were working before and now nothing.

Please, please, please, help.


Thanks for your post.
Based on your description it sounds like you are missing the programming driver. Are you running Windows XP, 7 or 8? 32-bit or 64-bit?

You mentioned that you are already working with someone over email, which email address did you sent your question to? Whats the subject of your email?

I will look through our email records and see if I can find valuable information in your email thread.


reference ticket number #2567.

The current problems are on Windows 7 64bit.

The problem sent on the email was for Windows 8 32bit.

Seems to be the same problem on both now but they are two separate types of machines.

Thanks for your help.


In this link there is a 32-bit & a 64-bit driver, please manually install them in your computers and let me know if the problem is alleviated.



Tried updating driver Windows 7 64 bit and get

Error 1316. The specified account already exists.

still no communication

Still no communication

error when installing driver because I think it is already installed.

Also, no communication from our Windows 8 machines either. Any separate directions for that would be appreciated.

I think I may have found part of the problem on both devices. It shows up as a VEX communication on the device manager and when I tried to download to the Cortex it changes to VEX Robotics HID, which is trying to use the VEX Cortex as an input device. I am not sure what I need to do to get this to show and allow updates and programs to be downloaded.

I tried the drivers you sent but i had already tried that before.

It show up on COM3 under the RobotC until I try to send anything to it and then it says that the device is offline.

It may be a driver issue but none that I have tried are helping anything.


I’m not exactly sure whats causing the problem, is this a School machine?
If so, have you tried it on a different PC (at home)?

Also I recommend you to reset the Microcontroller back to factory settings using the VEXnet Upgrade Utility. This will help us isolate the problem between an ROBOTC or a PC problem.

Let me know your results.


they are school machines. Is there a driver for windows 8 tablets that will work?

I am sure that it is on the PC side, probably a driver problem. The device connects but it doesn’t pick it up as a VEX machine.


Thanks for your patience.
As of right now, we are still working on a solution for your problem.

I keep you updated.


One variable that we found. We only have USB 3.0 ports on these tablets, could that cause a problem?