Compiler Malfunctioning

We had recently been working on programming skills for our bot, and so have been downloading code multiple times a day. We are using the most recent version of robotc.
Here’s the problem: sometimes, when we download code we encounter some strange issues. Sometimes, our arm doesn’t move up or down, sometimes our automated hang doesn’t work… these problems cannot be solved by restarting the robot. Redownloading the code doesn’t help, instead we have to make a change to the code file. Even if we don’t change the code itself (such as adding a comment or and extra space in a random location) the problem is fixed.
These problems seem to occur randomly, and seem to only be solvable by forcing robotc to recompile the code.
We know the problem is not an error in our code, nor is a problem with sending the code to the robot, so we believe it to be an issue with the robotc compiler itself. Our code is large (1400 lines in three files)… could that be the problem?
Any solutions or work around would be appreciated as soon as possible.

Team 224

This is not a problem I’ve heard of before or experienced myself. I would not expect the compiler to have any trouble with a 1400 line program, I have worked with far larger programs than that with more than 10000 lines of code. Perhaps send me the code and I can see if I can recreate the problem.