Compiling Issue VCS


Hi everyone,

I’ve been having some difficulty in compiling and downloading code from my laptop to the v5 Brain. I get the message up top that it is compiling, but I do not get any compiling errors (I know I am going to get some), the brain says that it is connected, and there is no update on if it has been downloaded or not either. I have used other devices where the code had worked as intended, and I am trying to run the software out on a different PC. I am also quite sure that it meets the requirements for running VCS. Could someone help me fixing this critical issue?



It may be a linker error that is currently not being shown, send me the program and I will test it for you.


It really isn’t a matter of testing the code though… how would I fix the linker error?


It may not be a linker error, I was just going to see if your code compiled and downloaded ok. If it is, there’s almost no way to debug that easily in VCS at the moment, I was going to compile it in another way to check it.

So explain the problem again, the code compiles but does not get sent to the V5 ?


Ah I see. The problem was that I was not getting a compiler error message to see what I needed to debug. This was paired with the fact that it was not pushing the code to the brain.


ok, still not sure I understand the issue you have. For example, this

#include "robot-config.h"
extern void foo();

int main() {
    while(1) {

Will show an Alert with compile error but show no useful information in the console or in the code as to what the error may be, is that what’s happening ?


There isn’t any compile error at all. The ‘compiling your program for your v5 brain’ message is the only thing that shows up and after that, does not do anything. Nothing in the console, and nothing in the compile alert that should show up.


Ah, I see. When you open the console (click arrow on the bottom of the VCS window) do you see something that starts like this ?

21:23:39 -- info -- changed directory: /Users/james/Library/Application Support/VEX Coding Studio/sdk/user/
21:23:39 -- info -- /Users/james/Library/Application Support/VEX Coding Studio/sdk/user/
21:23:39 -- info -- file removed: /Users/james/Library/Application Support/VEX Coding Studio/sdk/user/cxx.o
21:23:39 -- info -- clang version 5.0.1 (tags/RELEASE_501/final)
Target: thumbv7-none--eabi
Thread model: posix
InstalledDir: /Applications/VEX Coding


nope… the console isn’t giving me any information…


What system are you using ? It sounds like a bad install or conflict with something else. Have you already tried re-installing VCS ?


Yes, this is the second time I’m installing VCS, and having the same issues. I’m using a Windows 10 gaming laptop with an i5 and Nvidia GeForce GTX.


Not sure what to suggest, I have not heard of this type of issue before. You could try deleting the folder at

C:\Users\your_user_name\AppData\Local\VEX Coding Studio

and try launching VCS again. VCS will install the necessary support files in that folder.


@jpearman, if I may post an issue that I’ve experienced here, I’ve noticed that opening VEX Coding Studio and them closing it fairly quickly can lead to some of the necessary header files not being installed. This is just speculation, but could something similar be happening in @pkrish’s case?


could be, I’ll give that a go and run it by some of the VCS team members tomorrow.