Computer Not Recognizing Any Vex Device

This problem popped out of nowhere which is scary since my team has a competition this Saturday (10/26/19). I cannot download any code to our brain, either via wirelessly through controller or directly wired to brain. I’ve redownloaded the v5 drivers multiple times, I’ve restarted my computer multiple times, and I’ve messed around with the USB drivers in the device manager for hours now. No it is not the cable, I’ve used plenty cables already, and no it is not specifiic to one vex device. All cortexes and controllers refuse to be recognized by windows. And I am not the only one with this issue because this issue has been brought up on other threads, but they haven’t gotten any answers (V5 Driver Issues).

These types of problems are notoriously difficult to remotely diagnose. The problem can be related to hardware or software, you have to try and eliminate each possible source as the potential cause of the error.

Is the USB port functional at all on your PC ? Do other USB devices work, a mouse or thumb drive for example. Have you tried all USB ports on the PC ?

When the V5 is connected, does it show in the device manager at all ? If drivers are not correctly installed the V5 will usually appear as some sort of generic port, even perhaps a generic serial port on Windows 10.

Can you verify your V5 brain and cable by using another PC ?

Did something change on your PC at the point when communication was lost, did windows update ? Did you install some new software ? Is anti malware software blocking something ?


Another item to consider if this is a school owned computer they might have accidentally pushed a group policy which prevents certain drivers from being recognized. They might have accidentally removed permission and this could all be done with out the students knowledge.


how old is the computer and what kind is it other than is it windows core i7 or what

I can use other usb devices on my laptop, when I plug in the vex device I do see it in the device manager however there is a yellow triangle with an exclamation mark next to it signaling something seeming to be wrong, and I haven’t changed the state of the software of the laptop at all (no new windows updates, no new programs installed). The cable and brain also do work, it’s just that my laptop refuses to recognize it

This is my own laptop. I find using school tech a hassle because like you said, there are always little things the schools set up that get in the way

Pretty new laptop. It’s windows 10 i7

Hmm. Idk man. Is the port on the laptop broke or something

Are you running it as an administrator? If you are don’t do that, it can mess with file transfer (I know this through personal experience). If you have several accounts on that computer, use another one, or make a new one to get out of administrator mode.

EDIT: It could also be an issue of your computer not coming with a certain driver that it needs to work with the brain. Try looking online to see if you can find anything.

1 Like

Before anything test if the V5 brain is capable of connecting to another computer, compared to the laptop. If the same problem occurs on both computers try switching the cable with another micro USB cable. If both computers do not recognize the USB device, even if the wire is replaced, the problem most likely will be the V5 brain and you should contact VEX sales. If the V5 brain works on another computer but not the laptop, It will probably mean driver problems or USB problems. Try plugging in the USB device into a different USB port, and if not reinstall the V5 brain’s driver again. If it is still not figured out then tough luck, you may need to get a new laptop.