Computer not recognizing Vex V5 Brain

I am trying to connect a Vex V5 brain to my computer to program it using a wired USB connection but when I connect it to my computer, it makes the connecting sound but I am still unable to connect to the brain. I tried using a different brain, and a bunch of different USB cables, (my computer did not even make the noise with any other cables other than the original one). I tried uninstalling VexCode Pro V5 and reinstalling it, and I have also checked to see if the drivers are installed correctly (they are). Here is what it shows on Device Manger:

I have no idea what is wrong and would appreciate any help. This is my first time working with anything Vex related and I have tried everything I can.

Have you tried restarting your computer?

Have you opened Vexcode v5 pro? On the top, it should have a brain symbol. What colour is that? and it should not be in VEXcode IQ Technical Support , but VEXcode Pro V5 Text Tech Support

1 Like

If the symbol is grey, try using another cable. If that fails, you can restart the computer. If it is green, it should not be an issue when uploading.

What does it show under “Ports” in the device manager ?

What OS are you running ?

1 Like

I restarted my computer several times, it did not help.

In VexCode V5 pro, the brain symbol is grey

With another cable, my computer doesn’t even make the noise of a usb port being connected.

I am using Windows 10

You should see this if the V5 is connected. Until windows detects the V5, VEXcode will not be able to connect.


So the issue could be a number of things.

Drivers not installed correctly.
Bad cable.
Broken USB port on the V5. (try another brain)
Broken USB port on the computer. (try another computer)


The USB port on my computer works just fine with other devices, and the cables work fine too. I am pretty sure all the drivers are installed correctly, so I am going to try using another brain. Unfortunately, I won’t have access to another brain until next week, so I can’t do much now.

try connecting the controller to the brain and plugging in the controller via micro usb

Also try updating vexcode if it is not fully updated