Computer Problems.

So I have a Toshiba laptop and the computer will not read the cortex no matter how many times I try. I am debating whether or not to get a new computer. Although the computer is about 2 years old. No matter what we do it won’t read. All it says is that there is no link with the computer. But the cortex blinks as if it was connected. What should I do?

Try the other USB ports. If that doesn’t work, check for the right drivers being installed. If they are installed correctly and none of your USB ports work, reinstall your programming software and try again.

Other than that, I’m out of ideas.

We tried all those things and none of them worked. It started yesterday and we asked many other people.

Do you have a battery plugged in? Have you tried “hard” reinstalling (manually uninstall/install, rather than "repair"option), and used the driver package from the wiki? Have you been able to replicate the issue with with other microcontrollers? Is the computer recognizing it in the Device Manager (it’ll be a COM port)?

I would not resort to purchasing a new computer simply because a driver is not working.

Have you checked under the device manager? Does the cortex actually show up in there? I have never had a problem with my cortex but I constantly have that problem with Arduinos. This problem is not worth buying a whole new computer over.

Also try a new USB cable, they can go bad but still power the cortex.

It might be helpful if you give more details on your situation and what you have tried. For example I assume you are running windows, but what version? vista/ 7 / 8 ?

Are you running with Easy C or Robot C?

Have you tried connecting the Cortex to the Laptop with the USB A-A cable? or with a programming cable or Both?

if / when you connected the cortex to the laptop with the USB A-A cable did you open device manager and see the cortex? or a new ‘unknown’ device?

Itemize what you have tried and observed and you may get help faster, there are a lot of things that could cause issues it’s good to eliminate a few by understanding what you have tried and what your software is on the PC and Cortex.

Has this PC ever worked with a Cortex? Does the Cortex work with other PCs? are good things to identify as well.

I’m sure with some more information you can work through this. I hate to speculate on so little information, but I would start my investigation on finding out if Windows identifies the Cortex when the USB A-A cable connection is made between the Cortex and the PC.

Cheers Kb

I don’t have the program at my house, so I can’t give you very exact instructions, but I recall there being an option under “tools” in easyc where you can change COM ports. If you click on “manual select” you should see a list of available COM ports. Usually, if “COM 1” shows up without any others, you need to update the drivers under the START menu easyc icon. After you do, another COM port should show on that “manual select” list in easyc “tools” and you can put it back to “Auto select.” If that doesn’t work, your USB cables may be damaged.

Note: This is just from my experiences and ONLY works with easy c.