Confusion with PROS CLI Uploading

I love working with PROS and prefer to use the terminal when uploading projects but don’t always want to upload to slot 1 and to have the remote name to be the project name, ex working on a branch that has a focus. In atom under the pros tab, the upload button goes to a screen where you can select advanced features, slot, name, and description. I have noticed that it then modifies the project.pros file and adds the information to the “upload_options” located at the bottom of the file. But when I go to the terminal and type prosv5 upload it doesn’t follow the “upload_options”.

@hotel or @edjubuh I would expect the default upload to use the information in the project.pros file, is there something I’m missing or Is there an argument that needs to be added to the command so it uses the defined information? Thanks for the help!
1069B - Argonauts

As far as I know, it does. Can you provide an example project.pros file with which this doesn’t work?

Yep project.pros.zip (2.2 KB) (Sorry for the zip the forum won’t let a .pros file)
Also was doing some more testing the quick action button and upload button use the default settings. Only when I go to pros tab and click upload(screen with advanced feature) does it upload with the upload_option settings

Okay, that would be in line with what you said before about it not using the saved arguments. I’ll look into it.

Did some more testing and tried creating a new project and still had the same issue
Computer Info:

  • Running CLI 3.1.4
  • Mac OS 10.14.5
  • Atom 1.34

Note all uploads have been wireless
edit:
I have tried uploading via a cable and I get the unexpected end of JSON input(issue #37) and the upload freezes and doesn’t finish and when I turn off the brain I get a huge crash report that goes through the bottom of my screen. Don’t think they are related because the upload graphic shows slot 1 and incorrect remote name and then the upload crashes. I will get on the git issues and try to help since you can’t replicate it.

Hey @hotel were you able to replicate the issue and find a solution?