Connection Problems

Our robot is having connection. We tried power cycling, but the robot still won’t move, even while the orange cable was connected. We didn’t change the program and it was working before.

Did you change that battery?

Light patterns on the controller and cortex?

what is the connection type on the program? Is it USB or VexNet or Both

All the colors were green, but the robot still didn’t move.

Look on the program

All green lights means a solid connection. Can you post relevant code? I predict no while(true) loop in your usercontrol task.

We tried both, but when we did partner them with VexNet keys It costantly kept disconnecting, when we did it with orange cables (usb) it did not move.

What do you mean by relevant code?

Did you connect the joystick and the cortex to sync

Post ur program

Yes

Can you post the code running on the cortex, so we can diagnose an issue?

Do you want me to copy and paste it, it is 700+ lines.

yes

Give me five minutes.

NO. Just the part of the code that isn’t working. Relevant code. A description of what isn’t working. Which motors, which buttons, etc.

None of the buttons are working.

So do you want me to still copy the full program?

Have you tried a different controller and no just a portion please