Control System Not Working

I’m from #4476, and we’re booting back up our VRC team. We are trying to utilize the old control system for now, and will get the new gear later. However, the robot refuses to work.

We have tried multiple Google searches with no luck.

When we turn on our robot and controller, The GAME and ROBOT lights flash green on the CORTEX and on the controller the ROBOT light is flashing.

If anyone has any suggestions just let me know.

It sounds like the cortex is in standalone mode.

If the equipment has not been used for a while it’s probably best to update all the firmware. Master firmware is now at V4.25. ROBOTC is at V4.30.

Tell us a bit more about how everything is connected and what your plans for programming are (ie. EasyC, ROBOTC etc.)

Not quite sure what you mean by how everything is connected.
We have batteries in our controller, and a battery plugged into the cortex.

Our plan is to use RobotC to program the robot. We have been using a trial version for now.

We tried to update the firmware using VEXnet Upgrade Utility V4.1.7.
We received a code 10 error in the device manager when we plugged in the cortex to the computer.
Here’s a video of our lights currently.

Does your trial version of RobotC allow you to update your Cortex and Joystick from within RobotC?

I think the latest version of RobotC makes updating firmware for both the Cortex and the Joystick fairly effortless.

We have used multiple computers with a trial version, and one with a license. None of them have worked. We are unable to update the firmware because the joystick and cortex aren’t showing on the communication ports.

The cortex should show as a VEX Robotics communications device in the device manager, error 10 usually indicates some problem with the driver. Try reinstalling the VEX driver from here. (VEXnet USB serial driver).

First thing is to get the VEXnet upgrade utility to detect and upgrade the cortex. Does it show up at all? If so, what version is currently loaded on the cortex?

Try plugging the USB cable into the cortex with the config button pressed, that can help if the existing firmware is corrupted, it puts the cortex into boot load mode.

Same with the joystick, both cortex and joystick need to be on the same version. After upgrading connect cortex and joystick using the USB A-A cable.

If all the above is successful, make sure you download from ROBOTC using the VEXnet or competition modes (under a menu somewhere), download for USB only disables any remote control from the joystick.

For explanations of leds see this document.

We have installed the serial driver.
The VEXNet Upgrade Utility does not detect the cortex or joystick.
If it’s of any use, we have the old VEXNet.

Hmm, well VEXnet is not involved with connecting computer to cortex when using the upgrade utility so that’s irrelevant for now.

Which version of windows? (it is a real PC I assume, not a virtual machine on a Mac or anything like that). Do you happen to have a USB hub around as sometimes that helps?

We have used Windows 8.
We do not have a USB hub.

Bump. Looking for more suggestions. Will try them at our Saturday meeting.

Try disabling driver signature by holding Shift while clicking the restart button in windows 8, when it boots go to trouble shoot options -> advanced options -> startup settings -> restart -> click F7. Then plug in the cortex once it boots back up.

Followed all these steps through. Nothing changed. Not sure where to progress from here.

Now try reinstalling the drivers that you are having problems with now that driver signature enforcement is disabled.