Controller doesn't get picked up by computer

I recently started working on a robot for this year, and was uploading code to my controller to test our drive base when all of a sudden, our controller just wasn’t connecting. At first I thought it was a wire issue, unfortunate since the wire I’ve been using has always worked before, but I used other wires that have worked previously didn’t work either. I also tried connecting my controller on our laptop (Windows, my personal computer is a Mac), but I’d get this message whenever I connected my controller:

image

I’m considering now that the controller is damaged and we may need to use a different one (we have some spares since we used to run more teams), does anyone have an idea whether or not this is the case?

Thank you!

Are you talking about the remote control or the brain? The code should only be uploaded to the robot brain.

1 Like

If this is V5 (assuming it is by the tag) you can connect the controller to a computer via USB and download code to the brain wirelessly over VEXNet.

2 Likes

Sorry for the late reply, but yes, this is V5. I tried plugging to the brain directly instead of to the controller, but it yielded the same result, with the same message that the USB device wasn’t recognized by Windows. At this point I’m sure that it isn’t a damaged controller and brain, but I’m not sure where to go from here. The brain I’m using hasn’t been used since Tower Takeover, since our coach wants us to keep our Change Up bot intact for now. Would the incompatibility come from an outdated OS on the brain? Any input would be really appreciated.

Thanks!

Try restoring the brain to factory settings and connect the micro usb cable to the brain to see if vex code v5 asks to update brain firmware.

1 Like

No, it’s nothing to do with the vexos version, we have never changed the USB implementation. Was the last test on a Mac or a PC ?

2 Likes

We had this same “not recognized” issue a few years back, and the problem was that the drivers wouldn’t run.
Here’s how we fixed it:

That might help

Edit: Also, are all the cords you’re using the same model of cord? If you bought a bunch of the same cords online, then there’s a chance that they might only be “charging” cords, and not data transfer. That might also cause the problem.

1 Like

I’m really sorry for the super late reply but I tried the solution from the thread you linked, but it didn’t work. The cords I’ve used are different cords that have worked in the past, although now they don’t work.

In addition, I tried to connect to a different brain, but I received the same message when I connected my laptop to the brain. Does anyone have any solution?

Try restarting your computer and trying again? I’ve never ran into this issue before.

1 Like

Restarting worked, thanks so much!