Controller joysticks won't move robot forward

After following the advice from a previous post the the controller for my robot still will not move the robot forward . . . only backwards. ( All firmware updated )
I read the following . . .

(Drive FWD: Normal or Reverse is used to change the directions the motors spin when you push “forward” on the Joystick. If the left and right motors are correct, but the robot is driving backwards instead of forwards, change Drive FWD to Reverse.)

Still no luck
Can anyone offer another solution ?

Hi laveasley,

We’re sorry that you are having this issue. To help resolve this issue, we have a few questions about your robot that will help determine how to resolve this:

  1. Are you driving the Clawbot IQ or is this a custom robot of your own creation? If the robot is custom, can you describe how the Smart Motors are attached to the wheels?

  2. Can you provide what Robot Brain port that each motor is plugged in to?

  3. Can you provide what your current drive control settings are for Control, DriveTurn, and Drive FWD (under the Driver Control > Configure menu)?

  • Regards,
  • Art

Are you using Modkit? Is this a custom program or are you using the pre-loaded Driver code?

We have seen this issue on one of the default use of Driver Control with Clawbot configuration on newer superkit hardware purchased end of 2014. If you pickup the robot and wiggle the wheels or by chance it moves forward but most of the time it tries to move back. Reset configuration and use default settings. It will be apparent.

If you load a custom program (one of the provided samples from RobotC for example), it functions properly. It may be an issue with firmware, 1.12 onwards.

Is your issue similar?

Hi surgeon,

All four of the advanced sensors (Touch LED, Color Sensor, Distance Sensor, and Gyro Sensor) have example functionality built into the Driver Control program to demonstrate potential uses of these sensors. This functionality is described in Section 6.1 of the Control System User Guide.

The robot spinning on its own after the Controller joysticks are released is the example of the default Gyro Sensor functionality in the Driver Control program. (The robot keeps track of it’s current position and then returns to the original angle it was facing when Driver Control began running).

To prevent this from occurring, unplug the Gyro Sensor when running Driver Control. All of the sensors in the Driver Control program are optional.


  • Art

Hi Art,
Thank you. One of our team members bought a superkit. The default clawbot configuration did not work for drive forward. One side goes forward and one side tries to go backwards when driving straight.Sometimes it would move and then you can see the right side moving front and back continuously. We tried changing controller modules also. Then I tried our current robot driver control which uses all the sensors (just had to remove any extra motors). Works fine. He was supposed to contact support after that. Not sure of its status since Dec break. Other superkits were working fine with default Driver Control.

We have tried removing all sensors, replace motors from other kits, change joystick options in the menu, change motor f/r settings, etc and no change.


Hi Art
Thanks for the help

Yes I’m using a Claw IQ and the motors are using the standard config or 1 and 6 for the left and right motor, 10,11 for the arm and claw, 2 and 3 for the LED color, 4, 7, and 8 for the gyro , sensor and bump. The drive control is set to the default in that it is using two joysticks and everything else set to normal.

Note the brain reads: Update controller to 1.4 but the VEX IQ updater only allows me to update to 1.04

Thanks for any other support you can give

To ipanavigator
No not using Modkit . . . . using Robot C

Aloha laveasley,
We use ModKit right now for our team. One day we will switch over to RobotC. Our team has had problems ever since the firmware update of the brain (1.13) and controller (1.04). It sounds like you may have had this issue too. Best of luck on fixing your driving code. Go Team!!

If you are encountering an issues with a custom drive control program in ROBOTC, please post the program that you are using (you should be able to attach the .rbg file to your post) as well as a breakdown of what motors are plugged into which ports, and I’ll be more than happy to take a look at the code for you.

Just upgraded to 2.0.1. and the problem is solved :slight_smile: