Controller Won't Run Wirelessly!

My controller can run with it tethered to the brain, but it won’t work without it. The screen says “Connect Controller”, but it has worked for about one month already.

Has this happened to anyone else?

The most common cause of this is that the radios in the brain / controller are not fully inserted.

Remove them both, then re-insert them. Be sure to press down firmly until you hear them click into place. (Trust me, you won’t hurt anything)

If that doesn’t work, feel free to give our customer support team a call on Monday for some additional troubleshooting.


Thanks, I did that with the brain, but the controller radio doesn’t click. I pushed as hard as I could, and it still wouldn’t click. It also comes out easily. Maybe it’s broken because my partner dropped it very hard, and it’s loose.

On the controller, take the back cover off. Look for bent pins.

Insert radio put the cover back on, locking the radio in place. You should not be able to pull the radio out of the controller with just your fingers.


Thanks, that worked! It connects wirelessly now.

1 Like

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.