Cortex and Joystick not pairing

I created a program for our robot in easyc v4 and downloaded it to the cortex and joystick. It worked. It showed a wireless connection between the two controllers and everything was up to date.
Then I changed the program slightly (changed the motor ports in certain functions). When I tried to download it, easyc would show one of two things:

  1. there was a wireless connection and it detected the joystick but said the cortex was NOT up to date, when it was. So it wouldn’t download.
  2. it downloaded but with a pc connection and did not detect the joystick at all.

With a pc connection, the cortex and joystick connect through a cable but do not pair with the vexNET keys.
I have tried switching the cortex and joystick multiple times and have made sure that they are up to date. After everything I have done the cortex and the joystick will not pair at all.

Any suggestions on how I can pair the cortex and joystick?

NOTE: I am a beginner when it comes to programming. This is my first time programming.

Not sure if you have done all of this yet or not, but do the following:

If it still won’t work, try to run the program with the joystick connected to cortex with USB cable. Also let us know what the lights indicate when it is not working.

It may also be that your vexnet keys are not up to date
link text