Cortex/controller connection issue

So I jsut got the new vexnet keys, and just paired my cortexes after upgrading the master code and firmware. But my controlers robot light is blinking red in bursts of two. and the cortex and controler wont connect. i need a fast solution.

Did you update the firmware on the new vexnet keys?
A similar situation was reportedly resolved by:

  • update cortex and joystick to 4.22 firmware
  • pair them with AA cable
  • plug in white keys (dont work)
  • pair with AA
  • pair with black keys (works)
  • pair with white keys (works now)
    OR
  • pair cortex with a different joystick, and then this one again.

Sounds like it might be that you’re missing a firmware update somewhere.
Check out jpearman’s post to see his blinking light animation: https://vexforum.com/t/vexnet-2-0-oct-2014-firmware-readme/27409/1

As I understand it, the white Vexnet keys need to be upgraded to firmware 1.46.
To do that, there is a VEXnet Key 2.0 Firmware Upgrade Utility on this page:
http://www.vexrobotics.com/wiki/Software_Downloads

Then both the joystick and Cortex need to be upgraded to their firmware 4.23.
See VEXnet Firmware Upgrade Utility v4.1.5 on the same page as the VEXnet Key 2.0 Firmware Upgrade Utility.

If you’re using RobotC 4.27, then you might need to upgrade the RobotC firmware in the Cortex, too. With RobotC 4.27, you can upgrade the master firmware for both the joystick and Cortex via RobotC’s own upgrading method, which somewhat resembles the instructions on this page: [http://www.robotc.net/wiki/Manually_Updating_Firmware_(Cortex) except the RobotC hex file is now 1027, I think.

If all the different version numbers confuse you, you are not alone. :o](http://www.robotc.net/wiki/Manually_Updating_Firmware_(Cortex) except the RobotC hex file is now 1027, I think. )