Cortex Download Issues

our class is making robots for the starstruck competition, but my group is having lots of problems with the cortex.
on ROBOTC, we try to download to robot, and we almost always get a message saying: no communications link available to robot. check that your device is connected to the PC. but our cortex is connected to the PC, and we have tried:

-unplugging and re-plugging the cord.

-turning the cortex on and off.

-unplugging and re-plugging the battery.

-switching out the battery.

-switching out the cord.

-switching out the cortex.

-trying different USB ports.

-restarting the ROBOTC program.

-and yes, we’ve tried clicking Robot>download firmware> automatically update the cortex, but we get the no communications message again.

then, when we don’t get that message we get another one, telling us that our cortex firmware is out of date, and that we need to update from 2.23 to 2.25. so we open VEXnet upgrade utility, and it tells us that the firmware is out of date, and to press download. so we press download, and it looks like our cortex is downloading code, and then we get a message saying cortex is up to date, but then the master code is still 2.23.
and also, when we try to install default code, it says slave download failed, please reconnect and try again.

please help us, we don’t know what to do! O.o

Have you tried to look at the CORTEX Microcontroller User Guide?
Here’s a link: https://content.vexrobotics.com/docs/VEXnet_Cortex_UserGuide_081811.pdf
If the flow chart doesn’t help here are the instructions to reset your controller:

  • Start with the Cortex turned OFF (but with a battery connected).
  • Push and hold Config button in on the Cortex.
  • Attach the USB cable between the PC and Cortex.
  • Wait for the Robot, VEXnet and Game lights to blink green.
  • Release Config button.
  • Turn the Cortex ON.
  • Then in ROBOTC, click “Robot”, “Download Firmware”, “Master CPU Firmware”, “Standard File”.

Hopefully this helps :slight_smile: