Cortex flashing red

We are trying to use robotmesh to program our old vex cortexes. I have programs that I have used for years and when I download them, we get a flashing red light on the robot light. The same thing happens with every cortex we try.

Does anyone know what a red flashing light means? When we use the flowcharts, we get to where it asks if it fast or slow, but what is fast or slow? It’s flashing red once every ~ 2 seconds. The robot light battery on the controller shows green.

Is it the Robot light on the cortex, that means a dead battery. If it’s the vexnet light it is searching for the controller, did you remember to pair them by plugging in the orange cable from the cortex to the controller?

1 Like

It’s the robot light on the cortex. The battery is fully charged and works on another robot. Yes, they are paired and we still actually had the orange cord connecting the cortex and controller.

The programs I had in my robot mesh folder have worked for many years (I am a tech teacher) but now when we download the same programs to the cortex we get a red flashing light and the program does not work. The program compiles with no issues as well.

Can anyone help? Does RobotMesh even work anymore? Every program I download, even ones I have used 100 times, cause the robot light to flash red and nothing works. I have a dozen robots built in my classroom and kids waiting, but I cannot figure out what is happening.

can you provide a few more base details.

Mac or PC ?
Which version of chrome ?
Direct download to the cortex using an A-A cable or wireless download through the controller ?
Is a controller being used by the program or is this a fully autonomous program that does not need vexnet/controller ?

perhaps create a public project that you can provide a link for and I will test on a system here.

1 Like

Here is a link to a project:
https://www.robotmesh.com/studio/60256fb840fabb29702714d6

We are using a mac. Chrome: Version 92.0.4515.159
Direct download to the cortex using the orange cord.
I have tried both autonomous and a code with driver control, as well as a non competition project. All result in a flashing red on the robot light on the cortex and nothing works. The batteries are full.

ok, I’ll setup a test and get back to you with results later.

Which OS is the Mac running. The driver that allows the Mac to directly connect using an A-A cable with the cortex is very old and probably not supported in the most recent versions of OSX.

1 Like

Thank you very much.
10.14.6

I have a new mac with 11.5.2 and I am aware that robotmesh will not work on it.

so for that particular program you have a typo so the program crashes and causes red flashing led.

#region config
right    = vex.Motor(1)
claw     = vex.Motor(3)
arm      = vex.Motor(8)
left_    = vex.Motor(10)
joystick = vex.Joystick()
#endregion config

“left_” should just be “left”

as soon as you hit this line

left.run(joystick.axis3())

program would have crashed due to no object called “left”

3 Likes

I just changed the typo, can you try it again? I have tried this on 8 or so projects that have worked in the past and I keep getting the red flashing light. Do you know why it will compile with an error like that?

yea, that downloads ok. The program runs properly after connecting controller.
That error you had was run time error, so code would “compile” (whatever that means to robotmesh, convert to bytecode I guess) but would crash when run.

2 Likes

I used about 8 different programs that worked last year. I will try them again today, but I can’t see this being the error on all of them when they worked last year.