Cortex keep shorting out???

Please help I am new to the forum.

I am teaching a robotics class using VEX and it has been going great up to now. I am running 5 new “Clawbot” kits and they have ran great all year until now. What we are finding is that the short out while driving Meaning that the robots drive out with all systems go, then nothing, then it works, then nothing.

We are kinds stumped. We configured it over and over, checked electrical wiring will still no luck. We are running more than one robot at a time and thought it was something with the signal, but it was worked just find till now.

Any suggestions or help for a rookie like me would be greatly appreciated!



Can you give a little more information, what are the leds on the cortex and joystick doing (color, flashing etc.)? Is this all motors or just drive? Do all the robots now do this or just one of them?

On both the controller and cortex they both flash different colors, red, orange, green, in different patterns each time. Then it works then it stops. a minute or two later it shuts off then does the same thing.

When it shuts off all the motors shut down.

Thanks for the help


That sounds like a VEXnet connection problem. Are you running these at a school? Did they install any new WiFi systems recently that block adhoc networks? Are you able to take one of the systems that is having problems and run it in another environment to see of it works reliably?

Didn’t think of that. Will try. Thanks for being there to help


Still having trouble and seems to be getting worse. We diconnected the WIFI in the room and we cant get the cortext to connnect.

After we re configured it again like the directions said it actually got worse with a red light on the Vex net LED on both the controller and the cortex. The lights went when turned on the cortex…

orange, orange, green then the middle one went red and the other had no lights.

We are kinda stumped. Please help


Take a step back and debug the problem in a methodical way.

Are the batteries good in the joystick? Green joystick LED. Is the cortex battery good?

Can you control the robot when tethered with the USB A-A cable between joystick and cortex?

Is all the firmware up to date? master firmware is V3.23 in both cortex and joystick, use the ROBOTC software inspection menu or the VEXnet firmware upgrade utility to check if there is any doubt.

Have you swapped VEXnet keys, you may have a bad key.

Bring one system up and then label those VEXnet keys as good, test each system in turn and borrow the good keys if you cannot get a connection.

VEXnet keys are notorious for having problems, try and identify if some keys are working better than others.