Cortex Lights and Communication

Recently we’ve run into a problem with blinking lights. I downloaded a program into cortex and all of a sudden, the robot and game lights started blinking green while the VEXnet light was not on at all. We cycled the power and disconnected the brain from everything except the battery, but we still ran into the same problem. When we attempted to connected the joystick to the micro-controller with an A-A cable, all three lights (Robot, Joystick, and Vexnet) lights blinked green, but it wouldn’t run and did not receive any commands from the joystick. We re-downloaded all three firmwares, (Master CPU, Joystick & ROBOTC) and re-calibrated the joystick and the VEXnet, but the lights didn’t change until we downloaded the ROBOTC firmware. When this firmware was downloaded, the VEXnet and game lights started blinking green, and the robot light turned off. At this point, we assumed that the memory was cleared and that there was no longer a running program on the brain, so paired the joystick and micro-controller. We found that they were communicating, but the robot was running a very weird program, one which we’ve never created. So we downloaded our regular program, and it went straight back to the blinking green VEXnet and game lights-- our original problem.

    We have tried to address this problem several times, with and without pairing in between firmware downloads, but we always got the same result. Once after downloading all three firmwares again, ROBOTC told us to cycle power before downloading our program. Our robot was being powered by the A-A cable, so we unplugged it, and plugged it back in; when we did this the blinking lights problem started again. So we tried to download the firmwares once more, but this time, before trying another program download, we unplugged the A-A that was powering the robot, and the unoriginal lights that occured after the downloading of the ROBOTC firmware (with the VEXnet and game lights on, with the robot light off) resumed. After a series of testing, we concluded that the original problem lights (with the robot and game lights blinking green and the VEXnet light off) only occurred after we got the message from ROBOTC to cycle power.

       We tried all methods of downloading, through the regular programing cable and the A-A, and we also tried different computers, but the results were the same. This problem has happened systematically to three different brains (of three different robots) over the course of less than 1 day.  Has anyone had a similar problem?

It sounds as if there is something wrong with your program, as you said the default code worked (The “weird” code that you hadn’t written was the default code.), whereas your code did not. How about posting a copy of your code here on the VEX forum? I could look through it to see if there is anything strange, though if it compiled, and if it was screwing up VEXnet pairing… I don’t know, that’s what doesn’t really make sense to me. Well, just post it here anyway, and I’ll look at it.


P.S. You also might want to contact VEX about this problem, as I’ve personally never heard of it before; maybe they could give you answers.

EDIT: Never mind, I see that you already have. ( :rolleyes: Silly me.

At first we thought the code was the problem also. The only weird thing was that it was an unedited default template that ROBOTC made. So we downloaded programs that had consistently worked in previous competitions, but the lights still kept on blinking. So finally we decided to just download an empty code onto the robot, and that didn’t solve for the problem either.

My brothers micro-controller was working fine, until he downloaded code (which had been working for two competitions in a row) and then we got the weird lights too. :eek::confused:

Wow, this is strange. I really don’t know what to tell you at this point, except to wait for a reply from VEX.


Yes, I have run into similar problems, though not near as bad. For me, a problem almost exactly like the one you described happens now and then but not persistently like this. I use EasyC V4. I have actually had a lot of different problems with Cortex Controllers, (see the link below).