Cortex problems

I was testing my robot on our practice field earlier, when all of a sudden the drive motors stopped working. After a little bit of testing I discovered that motor ports 1-5 on the cortex brain were not working at all. Any ideas about what is going on? and is there any way to fix the problem? thanks in advance

If you let it cool down, and it starts working again, then you have just tripped the PTC circuit breaker for a while.
There are two PTC, one for ports 1-5 and for ports 6-10.
Note that tripping them repeatedly makes the easier to trip in the future (not good for high performance, good for avoiding fires)

See these other email threads for people with similar problems,
and the usual response.

https://vexforum.com/t/motor-tripping-circuit/20459/1
https://vexforum.com/t/strange-wheel-base-issues/20492/1

…See this thread for list of suggested information you should provide to get the best help;
[https://vexforum.com/showthread.p...ht=information

In every case where motors are in use, then stop, then work again later,
it means you are overstressing some part of the circuit, and causing some protection circuit to stop the motors.

The usual generic answers to your common generic question are:

  • change your motor to port allocation to balance each of left/right/arm motors across port groups 1-5,6-10
  • reduce friction in drive train
  • add programming to ramp your motors up and down rather than instantly change from -127 to +127
  • drive more gracefully (same as above, but by driver skill rather than programming)
  • stop trying to push the wall, or other robots
  • decrease your traction on wheels
  • increase the torque in your gear ratio from motors to wheels](https://vexforum.com/showthread.p...ht=information)

Even after I let it sit for a full 30 minutes it still didnt work. I even plugged in 2 brand new motors with no load on them, and they still wouldnt turn

Sounds like it is broken or burned up internally then.
Usually that happens just one port at a time, not on a whole 1-5 branch.
Did you notice any smoke or anything when it stopped working?

Try calling Vex to ask about getting an RMA (Return Material Authorization)

Nope, no indication whatsoever of any problem. We put the robot on the field, and the motors would not move

We had the same problem last week. At first we thought we had tripped the circuit in the cortex but were surprised because the robot was working fine an hour or more before, no one had been driving & abusing it as they were just testing their code out, there is enough torque on all of the motors so they shouldn’t stall, yet all the ports from 1-5 stopped working. After testing everything & we figured a fuse in the cortex must have burnt out as it didn’t work even after one day had passed. We did notice that the WiFi key was hot so the next day we tested all the WiFi keys & that one was bad. We put in a new one but that didn’t work so we redownloaded the Master Firmware & the RobotC firmware. It didn’t download initially so we inserted a paper clip in the config hole as we connected the USB-USB cable into the cortex. After a couple of tries it worked. That seemed to have fixed the problem. Don’t know if the hot WIFI key could have somehow messed up the ports or vice versa. What’s spooky is that it happened to you too and we still don’t know what caused it & if there is a problem with our cortex. Hope redownloading the firmware will help you. :confused:

@jokai Were there any other symptoms other than the motors not working and the wifi key being hot?

No. Had to redownload Master firmware several times before it downloaded but once it did, the 5 ports worked again. Had a tournament this weekend with not issues. Can’t figure out what made the ports all shut down.