Cortex Sending Data But Not Power?

While we were testing earlier, we ran into a peculiar issue.

[INDENT]-When a motor was plugged directly into the cortex on any port (With Motor Controller 29 on 2-9 and without on 1 & 10), the motor did not run in either direction.

-When connected to a power expander (wired to the same port), the motor worked as intended (same code, no change in cortex status).

-We switched back and forth between PROS and RobotC to diagnose potential code/firmware issues.

-Motors connected to the cortex have run on rare occasion after repeated attempts to restart the cortex, but 99% of the time only the motors connected to the power expander have run.

-We tried resetting and re-flashing the firmware repeatedly. All lights (except Game) were on. We tested with a competition switch as well and received the same results.[/INDENT]

It appears as if the cortex is sending data to the motor ports, but not power. This is normally the case when the cortex is powered off and plugged into a computer, but all lights are green.

Does anyone know what might be going on?

The motor runs on all ports but nowhere near full speed. We tried with two different motors.

While doing this the robot light turned red, and after resetting it the robot is working fine. This happened last Sunday as well, and the robot was not working again this morning so we are at a loss.

We just managed to isolate the issue. Whenever there is a Y cable plugged in to the cortex, none of the motors run. As it turns out, we Y’d the port off to two motor controllers instead of Y’ing the motor controller off to the two motors.

Edit: Y’ing a port off to two motor controllers does work. It turns out there was a manufacturing error with one of our y-cables:

If I understand what you’re saying correctly, that is exactly what your supposed to do: Y one port to two MC29s to two motors.

From your description, it sounds like you might have a loose connection with the main battery and the cortex is running off the backup battery, but then again I don’t think all the lights should be green. Do you have a backup battery, and if so have you tried unplugging it?

EDIT: Disregard that, just saw your update post. Good to hear it was only a malfunctioning wire.

Not a good idea unless you know what you are doing.

Plugging a two wire motor to center (red) and outside (black) connections would send battery power to the motor which is OK for a test, however, plugging to center (red) and inside (white) connections may damage the cortex. Specifically there is a chance it will damage the ESD protection diodes as described in this thread (that Kevin conveniently linked to earlier today).