Cortex slow red blink for robot while using keys and tethered

Hello! I apologize if this problem already listed in the forum but my searching skills are lacking at this time :confused:

We’re using RobotC programming, Cortex, and the older Vexnet keys.
The cortex and joystick have been updated to the latest firmware.

There is a simple joystick program loaded using 4 motors:

#pragma config(Motor, port2, right1, tmotorVex269_MC29, openLoop, reversed)
#pragma config(Motor, port3, left1, tmotorServoContinuousRotation, openLoop)
#pragma config(Motor, port4, right2, tmotorVex269_MC29, openLoop, reversed)
#pragma config(Motor, port5, left2, tmotorServoContinuousRotation, openLoop)

task main ()

while(1 == 1)
	motor[left1]  = (vexRT[Ch2] + vexRT[Ch1])/2;  // (y + x)/2
	motor[right1] = (vexRT[Ch2] - vexRT[Ch1])/2;  // (y - x)/2
	motor[left2]  = (vexRT[Ch2] + vexRT[Ch1])/2;  // (y + x)/2
	motor[right2] = (vexRT[Ch2] - vexRT[Ch1])/2;  // (y - x)/2


The software inspection lists this:

Communications Link: USB-to-Serial Link (COM5) from Cortex to PC

Standard Firmware File Names:

VEXNET Joystick: .\Firmware\JOY_V4_23.BIN
VEX Cortex Master CPU Firmware: .\Firmware\CORTEX_V4_23.BIN
VEX Cortex CPU Firmware: .\Firmware\VEX_Cortex_1027.hex

VEXnet Joystick Integrity:

No joystick connection. Direct USB-to-Serial connection to PC.
Joystick State: No joystick. USB-to-Serial

Cortex Master CPU Integrity: Value Status

Firmware Version: 4.23 Up to Date
Main Battery: 7.6V Good (>6.5V)
Backup Battery: 9.2V Good (>8.7V)
Team Name: “9965A” OK

Cortex User CPU Integrity: Value Status

Cortex USER CPU not responding. Firmware may need to be reloaded.

So, we are able to operate the robot both tethered and using the keys. The Robot LED first starts out solid green and then changes to a slow blinking red. We can still run the robot with the joystick ok most of the time for a long period of time but sometimes we lose connection. Any thoughts?

I’ve reloaded the firmware a ton of times and still get the same inspection comments. We compete in a few weeks and want to work out the bugs before loading our competition program.

Thanks for the help!

How old are the keys themselves? The program looks good, the firmware seems to be up to date, and the fact that the VEXNet connection starts out live and strong (but suddenly drops) is indicative of the potential for a bad key(s), especially if they are older.

Have you tried swapping the keys with new ones to try to narrow down which one could be giving you the issue?

The keys themselves are 4 years old. I’ll switch them around and see if that stops the red blinking robot LED. Interesting though that the Vexnet LED stays green even though the robot is blinking red. Just noticed this…when tethered I get an orange blinking robot LED.