Cortex stuck in bootloader mode, Help!!!

I was updating our cortices to VEXnet V 4.1.7 using the Utility downloaded from the VEX site. Our first cortex and joystick had no problem when I did it yesterday and then went through the PDF to set up the Windows 8 to accept the Keys to check them, but today, when I tried upgrading our other cortices, it said I needed to upgrade the bootloader from V6 (which it did for the one yesterday too). When I hit the button, the computer stopped talking to the cortex and the cortex had a slow blinking green light for “robot.” I thought it was just this cortex, because the cortex is a old cortex that hardly works, but then it did it with the next cortex I tried. When I researched the light code it said that it is the bootloader mode code.

Is there any help you could give me on how to resolve this problem and get the cortex working again? Any extra information would be helpful.

You probably just need to re-download the master firmware, try restarting the cortex while holding down the config button, try using a different USB port

Alright I did something with the configure the button and it cleared out the master code some how and I was able to download the new master code but I can replicate my results. Do you know what I did?

I’m pretty sure the VEXNet Firmware update utility is ONLY for the White 2.0 keys. Plug them into your computer straight up and then you’ll be able to update them.

The cortexes should only take the VEX Master CPU firmware and the RobotC firmware or whatever you use. Same with the Joysticks.

You were probably upgrading the master code in the cortex and the upgrade failed. This is not uncommon and may happen for a number of reasons. It’s very unlikely you were actually upgrading the bootloader (which is a different small program that allows the master firmware upgrade). Once the master firmware upload failed you had to manually force the cortex into bootload mode by pressing the config button. Don’t worry about it if everything is back to normal now.

I have at least 30 cortex to update for the upcoming Dallas BEST season.
Using a windows7 notebook (same as past 3 years),
doing firmware update with Vexnet Upgrade Utility 4.1.7,
to CORTEX_V4_25.BIN,
I have about a 50% success rate, with or without using paper clip, and trying several sets of USB A-A cables. If next pass doesn’t go better, I’ll have to try putting the cortex in the freezer first.
I looking for other ideas to improve firmware update success rate.

In a separate note, I also need to load BEST specific default code. If I could get the firmware updater to use my code, it would save me from a second pass of loading default code with easy C. I have the HEX file from my default, but I don’t see a place in the updater directory where I can swap the Vex default with mine. They seem to be BIN files.

I was able to get the cortices to reset and work again skipping the bootload upgrade. Twice though, I had to call VEX Tech Support so that I can get an access code so the cortex could write a new ID. I have some of or cortices running the old software that I’m not going to mess with unless there is a problem with the programming software or game computer as it was such a pain to do those 4.

Using a different cable and computer, and using the freezer method, I was able to update all but 2, which need access codes update from Vex. I think the condensation after freezing was not good for them.

Seems a bit extreme. We upgraded dozens of systems at the world championshipswith a 95%+ success rate. The only ones that are usually problematic are the ones with very old bootloaders (earlier than V6).