Cortex without PC connection

so i have a program that i made with RobotC on my computer, and it is connected to my Cortex using the provided USB cable. i can start the program when it is plugged in, but it stops functioning when i unplug it. I have read in various places that you have to power off the Cortex before unplugging it, but nothing seems to work. the robot is a vehicle, so it cannot be tethered to a computer. i would like to be able to run the robot with the code and not have it plugged in to anything. i would appreciate your help. thanks.

You haven’t said what you tried.
You haven’t included the program.
Try the sample programs included with RobotC,
and/or google for “beginners_guide_to_RobotC.pdf”

First thing to try is to go ahead and change Robot > Vex Cortex Download Method to Download Using USB Only. If it is on the default setting, when you first turn the cortex on it tries to find a connection to either the computer or to a controller (via USB cable or VexNet key) which can take awhile - if you set it to download using USB only, it will go straight to the code that is already stored on the cortex.

Secondly, you should do things in the following order:

  • Download Code
  • Turn robot off and unplug cable
  • Turn robot on
    which will mean that the Cortex starts from the beginning of the code that you’ve put in it straight away.

Hopefully that solves your problem!

1 Like

i tried that exactly, but whenever i power up the cortex again, i get red lights and it doesnt run the program.

Can you provide the Program for us to test… Or a Sub Portion that causes the same Issue???

i dont have access to the program right now (its on a different computer), but ive tried sample programs as well, and they dont work either. i know that the program is properly uploaded to the cortex because it will run the program no matter what computer it is plugged into, regardless of whether it has RobotC or not. i have tested it by plugging the cortex into a netbook running linux, and it works.

That is a Clue… Since there is no Linux Support for the Cortex, it must have something to do with the USB Port and the Power it Supplies…

I wonder if there is an Issue with the CPU being Powered from the Internal Regulator, and it currently can Only be powered from the ( Programming ) Computer…

thats what i was thinking. although, the cortex does work with a vexnet adapter and a wireless joystick, but the adapter provides no power to the cortex.

So maybe it needs a Joystick or Computer connected… Hm…

i think so, but the cortex wont perform the code when the joystick is connected

So when the Joystick is Connected to the Cortex, by VEXnet or USB A-to-A Cable the Cortex Won’t Perform Code??

And when the Computer is Connected to the Cortex, by USB A-to-A Cable the Cortex Will Perform Code??

The Joystick doesn’t have Power for the Cortex, on VEXnet or with the USB A-to-A cable…

But the USB A-to-A Cable to the Computer Does have Power… With Windows or Linux…

That would suggest that either:
The Power the Computer Provides is enabling the Cortex to Perform Code.
There is a Device Driver that is enabling the Cortex to Perform Code.

I would place my Money on the Power, but I guess that it is possible, that the Cortex is needing a Computer to Enable It, but neither one of those is not the typical Operation of the Cortex…

alright, i figured it out. i needed to update the firmware for the joystick and i also did a full power cycle

I guess that makes sense… There is an Interaction between the Two Units, and that was the Issue…