Cortex won't connect to computer

I can’t get my cortex to connect to my computer. We had it connected then it unconnected and won’t connect. I tried to use an A to A cable. I also tried different communication modes. It won’t let me update the firmware. Do you have any suggestions?


  1. Try holding down the “config” button left of the battery connector while cycling the cortex before updating (the cortex should blink differently that normal)

  2. Try a different USB port on your computer

  3. Try a different USB A-A

  4. Look at the troubleshooting guide here

  5. Contact VEX support

Have you tried it?

Also make sure the appropriate drivers are installed on your PC, they can be found here

manually update the firmware.

You could also connect through a programmer cable and the controller, as shown here:

If your running a linux machine I believe there is a bug regarding upload to the cortex using A to A. Instead you need use a programming hardware kit, like in the post by @hotel

From time to time I’ve even found the programming kit to work better than direct A-to-A on Windows too :slight_smile: