cortex won't connect to computer

Can’t find this same situation anywhere. My cortex won’t connect to my computer. Robot light is not lit, and vexnet and game lights are constant red. When I run the vexnet upgrade utility software it does not see the cortex when plugged in. Tried putting a paper clip into reset hole. If I do this when plugging in all lights turn green, but computer says it does not recognize the usb device. If I unplug and plug back in red lights return. I have run out of options to get this connected and running. Please advise. Thanks!

Try a different cable

Check the device manager and see if the cortex ever shows up as a device. When you press the config button and connect the cable it should show as a HID device otherwise it should show as a COM port. Make sure you also connect a battery, some computers cannot supply enough power over the USB cable. I find that using a USB hub helps with some computers (especially Macs) so you could also try that.

Yes it shows as a HID after pressing the config button, but does not show up as com port after I unplug and replug it in. I have battery connected but no difference. upgrade utility doesn’t recognize it in either scenario.

Try updating Robotc. We had this issue last year, and it took us a couple of days to figure out.