Cortexes won't connect

Hey guys, I know this is a constant problem, but I can’t get the vex cortex to update firm ware.
• “No Communication link available”
• “At least 3 cortexes will not connect to communication mode.”
• “2 Currently do not register as Vex Robotic Comm Ports, instead they show up as IFI MCP2458 HID.”
• Before they stopped registering as Comm Ports those 2 registered as having communication, and I tried to download the firm ware. Then, they gave an error “Failed to initiate Master CPU downloading Mode”

• Another cortex accepted a blank program - then crashed robot C. When I re-opened RobotC, and tried to load the blank program I got the firmware-52 error(see attached image) and robot controller failed to respond (see other image). Then I tried to update the firmware, and got a loading bar"wait for 15 seconds…" and then the error “Failed to initiate master CPU downloading mode” (see attached). The vexnet upgrade utility recognized and updated that cortex. After that it still shows up as a Comm port, but robot C still won’t load code into the bot, and still cannot update the firm ware.

Things I have tried:
• Vexnet upgrade utility. When the cortexes are recognized as Comm ports it works - but they still wont accept firmware upgrades.
• Uninstalling and re-installing the VEX USB Driver
• Power cycling - every which way.
• Changing batteries and checking the voltage on the batteries
• Different USB Cables
• Different USB Ports
• Running RobotC as an administrator

It was working fine up until recently, I was able to update the firmware when there were problems connecting to the student PCs.

PC features:
Windows 10
RobotC is up to date
We do a lot of virtual worlds

Please help - my class is going to grind to a halt if I can’t get these working.
controller failed to respond.PNG
Failed to enter master cpu mode.PNG
Firmware 10-52.PNG
wait up to 15 seconds.PNG

Try doing a config reset on the Cortex. Connect the battery to the Cortex with the Cortex off. Use a small allen wrench or large paper clip to hold in the “config” button on the Cortex. Turn the Cortex on, wait for all of the lights to settle down and turn green. Release the “config” button. Turn off the Cortex. Now try updating the firmware. You should be able to now. If this doesn’t work, you have MAJOR problems.

Lets mark that down as officially major problems then…

Wow. Have you tried this on multiple cortex units?

Yea, and they were functional before, leading me to believe its a problem in my robot c installation. I’d keep testing on my other cortexes, but I’m afraid they might end up corrupted.

Have you tried a different laptop/PC with robotC installed?

I only have one computer with a functioning licence and admin privileges.

Update: robotC had somehow become corrupted. Re-installing with the repair utility seems to have fixed the problem

Admin privs are your only issue, then, since RobotC is free for your purposes.