Dead motor

My first post, so introduction is due: I am a mentor of team 2014, Sandpiper. We started our robotics program Dec 2014 so we are still pretty new to this.
On the last competition (NorCal), a motor died for us at the worst possible time - while the driving team members waited in the queue. It worked the round before, but when they tried to turn on the robot (mostly a basic clawbot design), it complained about one group of ports and by elimination, we have figured out it was the claw closing motor, disconnected it and finished that lap just pushing bricks. Thankfully we had a spare motor to use for the rest of the event.
The brain recognizes something is connected to the (group of) port(s), but can’t talk I2C to it, so I venture to guess the motor inside is connected directly to the pins (thus the brain senses the load), while the feedback encoder is fried. We have tried connecting just that single motor to different ports, updating, trying to detect it, but nothing helped.
My theory is that while the little engineers were waiting, they played with the movable features thus induced current into the unpowered system. There are obviously protections on the motor ports, so any excess current from motors gets routed to the power line (this is why the display lights up in such a case). Perhaps because the claw motor had the longest wire, the induced voltage wasn’t clamped low enough by the brain, thus destroying the motor electronics.

What shall we do with the motor?
Can the design be made more robust, e.g. by adding local voltage clamp to the motor?

Hi nenik,

We’re sorry that you have encountered this issue. We are currently investigating a firmware update to prevent this issue regarding motors or sensors becoming unresponsive. In the interim period, to help resolve your unresponsive Smart Motor, please contact our technical support folks at or by calling +1-903-453-0802.


  • Art

We have experienced similar issue many times this year. The motor might not be dead. You might see one of two things: I2C Error motor port 1-3, 4-6, or whatever; or Update Needed with a port number and Motor displayed. It might go away if you power off for a few seconds and then on. That I2C error might disappear. If Update is needed then you have to let it update. Although the motor was fine just a few seconds ago, all of a sudden an update will be needed.

At times after it does that, you might even get an update needed for a sensor that was fine just a while ago. Again same solution, It is like a routine now (several times during tournament, routine weekly).

Art, hopefully this update will resolve both issues.

Thanks, I’ll try contacting support.
For us, this motor is pretty consistently dead, even if plugged alone into different ports. Updater won’t see it at all. We have experienced intermittent failures in general before, but this is different.