Debugger

Hi, this year our programming software is Vex IQ Graphical. We are completely new to programming so we have been making a small program but when downloading to robot a pop-up box telling us either to debug or abort debug. After we tried checking the vex utility but the computer did not detect anything. Although the computer said there was an unrecognized device in the bottom right corner of the screen.

1 Like

To be clear here, are you using an IQ brain or a V5 one? Your post is categorized in a non-IQ category. Also, I highly recommend switching to VEXcode, not VCS, as VCS has been discontinued by VEX.

1 Like

We are using a VEX IQ brain. For code, we are currently using ROBOTC.

1 Like

Are there any other applications open trying to communicate with the IQ brain (VEXcode, VEXos utility, etc)?

Is the IQ brain running the latest firmware?

Can you post a screenshot of the particular behavior you describe?

Does this same behavior occur when you connect other brains? Does it occur when you connect the same brain with a different cable? Are you able to download code to this brain from another programming package?

You might also consider switching to VEXcode IQ blocks - it’s the way forward for graphical programming of IQ robots in terms of official support and new features.

2 Likes

Not that we know of, no. The brain

The last time we checked, which was in September, it was updated. We haven’t been able to check lately due to the brain not connecting with Vex Utilities.

unnamed
Here’s the screenshot you requested ⁠—when we click either of debugger options below, the message pops up again.

We haven’t tried other brains yet, but we have switched the computer and cable multiple times.

Our administrator has told us not to use VEXcode IQ Blocks in favor of ROBOTC, for reasons we really don’t know. We’ll be asking her about it soon.

1 Like

Ah, well, that appears to be telling you pretty clearly what’s wrong - looks like you’ve configured several sensors in your program that aren’t physically connected to the robot.

Do all the sensors you set up in the program appear to be physically connected to the correct ports on your brain?

2 Likes

Oh, that makes sense! Thanks for help! We must’ve set the code to include sensors that weren’t hooked up to the bot just yet.

2 Likes

Make sure you have ROBOTC set up for IQ and not EDR. Always good to check.

1 Like