Default project not even uploading?

This is quite strange. I opened up a new project in pros, clicked the quick action button, and then I get this:


Sorry, laptops wifi is broken so I can’t ss it. I’m not even allowed to exit that screen, I have to restart the app,but I’ll get to that problem later. How do I fix this error? I literally hadn’t touched the code.

Btw if this is something that’s super easy to fix, sorry I’ve never done pros before and the only people who did are now in college lol

Based on my experience of programming rather than PROs that is caused by using a value the function does not understand. So it looks like something is in your code where a value is incorrect (but still formatted correctly). This means the various VEX libraries now are having errors trying to process this dodgy value.

So you might have accidentally typed in a random character where it shouldn’t have been. The top of the error message (which doesn’t seem to be in the screenshot) should list the line in your program with the dodgy value.

well, I didn’t even type anything in, I jsut clicked new project and then clicked upload with all the default code.

Is your Brain running the latest firmware?

… I’ll get back to you in that one.

Now it is, same error though.

nah in this case it’s some interaction with vexOS when trying to upload the project to the brain.

@ op: 90% of the time this issue is solved by updating the brain firmware and also the controller firmware (have the controller plugged into the brain when updating)

7 Likes

Updated the Brain (not the controller) but it’s still broken. didn’t get to update the controller though, forgot to do it and by the time I remembered I already had to go. Assuming that it’s the 10% of the time, what is your idea here?

if it’s not the controller then make sure the CLI is up to date also

7 Likes

If you mean by Command line interface the IDE, then yes, atom is up to date. It seems that no one has a clue what this is, I surely don’t, can you guys direct me to anyone who’s like a developer or soemthing for PROS? I feel like it has to be a very simple problem.

I’m sure some of the PROS team can help, and James may also be able to help. But’s it’s a really nice weekend across most of the US and there are a ton of graduation parties happening that are keeping people off the forums.

Oh right, graduation… I honestly forgot since our school ended earlier than most people

1 Like

you need to provide the full output when you try an upload, forget Atom, use the command line and paste the full output here in code tags, the screen shot is not useful as it’s showing errors after whatever was the initial reason for failure. Make sure all other programs that may try and communicate with the V5 are closed (VEXcode etc.)

but in general, if you want to be a PROS user you have to figure out much of this on your own, what’s different about your system as compared to what’s known to work, is correct version of python installed etc.

and unless you are trying to upload wirelessly, controller firmware is not relevant, if you are, then try a direct connection to the brain and see if that works.

6 Likes

i was doing a direct connection, which is why I was had no idea why peo0le would say controller first. Currently have to go do something, but tomorrow I’ll run it and get you the information

because you never said as much and the majority of the time we’ve seen errors like these, it’s been because of a wireless (i.e. through the controller) upload with mismatched firmware versions.

“The CLI” is the part of PROS that does the work of talking to the V5. You can check what version you have by running pros --version from a command prompt. Similarly, as James auggested, you can get the full output of the upload command (to copy and paste, for example) by running pros upload in command prompt from inside your project folder.

… hi

14 Likes

yeah uh about that, I don’t have robotics for two weeks now. so I can’t even help you guys help me with the brain downloading. I’ll get back to you guys then, sorry.

1 Like