Did my Cortex Joystick Die?

When I turn on the joystick all four lights flash red and then off. We have changed the batteries and made sure those batteries are charged by checking them in other joysticks but still nothing. What is wrong with the Joystick?

This happened to us as well, but with the Cortex, not the joystick. We just reconfigured the Cortex, and then re-downloaded all the firmware starting with the VEXnet Firmware download utility

I saw this exact same problem at an early Middle School tournament I refereed at. We swapped out batteries and everything, tried multiple things, reloading firmware and nothing worked. I think one of the students dropped it, and so probably broke it in that way. Do you know if the joystick could have been dropped? I’m assuming that it is most likely broken, anyway if you have tried downloading firmware and everything as well.


Well if it is the *exact *same problem, all 4 lights flashing, I think it is an indicator that was built into the system. Electronics are built pretty solid, unless cheaply made or has a brittle part… So you can usually drop things and they’d be okay. Mostly everything is usually secured on a PCB. I don’t think dropping it could be the culprit.

We treat the joystick like a newborn baby… theres no way it was dropped. and the firmware update wont work because it doesnt recognize the joystick.

In our case, this happened when we pulled out the USB during a firmware download.

We didnt drop the joystick and the Firmware utility doesnt recognize the joystick.

Did you reconfigure the joystick?

Well, I know I said dropped but I heard that someone had thrown it. I do not remember if anyone ever ended up fixing the problem, I don’t believe they were able to.


Well who hasn’t been tempted to bash the controller against the wall when it doesn’t link? :smiley:

Have you used a paperclip to hold the config button down for a long time,
(this may be what the previous posted word “reconfigure” meant)
before trying to link to firmware upgrade utility?

I had one joystick that required endless (20?) attempts of battery in/out, config button, firmware reload, in various combinations and orders, before it started working fine.

Hahahaha. XD I can tell you I have. XP

This happens to my team a lot to. usually, if we cycle power on the joystick four ofr five times it works. It sounds simple, but we didn’t think of doing that until after an hour of trying to fix it by re-downloading firmware and changing batteries. Hopefully, you can fix your problem, I know how frustrating it is to have a joystick that doesnt work.:slight_smile: