Different errors in PROS and Github

Hey guys so basically i am having wierd errors in PROS and github and since i didnt want to make two different topics i put it in one.

So when i try to build my project i get this error.



for github, when i type in git add . and press enter this pops up


and i have one more question related to gyro

when i was trying to calibrate the gyro. the values of the gyro keeps on counting up for no reason. The gyro isnt moving at all but its still counting up and when i printed the errno value i got 22 (if anyone knows what that means). Please help because our provincials comp is coming(our only way to get to worlds). So please help if you can.

(sorry for the messy topic i was in a bit of a hurry)


I haven’t used pros much, but I have some generic coding and gyro pointers…

When I’ve used the gyro, I needed to make sure the sensor scale was accurate. I don’t remember exactly where I found it but a vex blog site had some good documentation on robotC code to set this. If you can tune the sensor scale, that should help with the large drift. Try searching for vex gyro set sensor scale or something of that genre. (Will post link if I can re find it)

As for your PROS error, I’m by no means versed in this specifically. I’d suggest looking at the lines specified in the error log (main 27:1:1089) and make sure your syntax are good.
Also just check the little grammar stuff. A semicolon or bracket can escape even the best of us. :wink: Good luck


I already looked at main and there isnt an issue there so i dont think its that.

as for the gyro i will look into that thanks

We used to have that problem with the gyro just counting up. Try updating your kernel to the newest one 3.1.6 and also check that you plugged your gyro in the right way.

As for when you are building your project, try adding compile_commands.json to your .gitignore, deleting that json file and then recreating it by running prosv5 make clean all. When we were pushing from multiple computers and then fetching that file from a different computer, it would mess up our compile.

oh ok thanks i will try that @815J

i still get this error
and this is how i added it to gitignore


Then instead of that, try running prosv5 build-compile-commands inside your project directory and try compiling again.

delete compile_commands.json
make clean
prosv5 build-compile-commands

1 Like

The compile _commands.json worked but i am still having issues with the gyro does anyone have any suggestions.

From the last post you opened about the gyro:

In the interest of keeping posts on topic, you should probably update that other thread with your gyro troubles

ok got it thankyou i will update it there