Distance Sensor 2nd Generation; distance will not change

I have 30, second-generation distance sensors. Now and then, one of the sensors is stuck at a distance and does not change. I am using a Gen 2 Brain and going into Sensors. I have tried powering off and back on. Plugging and replugging, and nothing seems to work consistently. Today I had a sensor "freeze at 7inches. I changed to MM, and it was still frozen. I then put in a sensor that I had marked as frozen on a different robot, and it worked!
Has anyone seen this issue?

Noticed your prior post. Just curious if you were able to get the G2 distance sensors to work. I’ve noticed a few quirks such as initial accesses returning incorrect distances, intermittent inaccurate reads, etc.

Since I have written my previous post, the Gen 2 sonars have been working well. One difference between Gen 1 and Gen 2 sonars is that they read as zero when the Gen 2 sonars are far from an object. I had to use an AND block. For example: stop when the distance is less than 4 inches and greater than 1 inch. The greater than one inch eliminates any zero readings. Maybe VEX Code had an update but my sonars seem to be working

Are you using 2nd Gen sensors on 1st Gen Brains?

Calvc01, we have G2 Brain with G2 distance sensors. Thanks kinnama1 for your reply. Not sure I understand your AND block. I see the greater than one inch eliminating any zero distance readings but not sure I understand “less than 4 inches” condition?

The kids are using print to console blocks to display distance sensor readings. In almost all usage, the distance sensors are quite accurate, reading distance to the field walls. As mentioned previously, the initial reads are incorrect but seem to settle after a half second or so - not a big deal. As the robot moves, however, we see instances where the sensor reading change as expected but, occasionally, an invalid reading pops up (e.g., readings like 1.2, 1.4, 1.7, 38.1, 2.0, 2.3…).

BTW, I think the G2 Distance sensors use lasers, not sonar? As an aside, the kids are reading the sensor value into an variable. On some occasions, we see print outputs on the console from the distance sensors that resemble IP address (e.g. xxx . xxx . xxx). Weird.

Sensors do take some at the start of the program to begin reporting accurate data. Putting a delay before printing values might help with the incorrect data being displayed.